summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2007-01-29 18:31:45 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2007-01-29 18:31:45 +0000
commit63f1781b2a21d39d7a502118469ae022f6a14c14 (patch)
tree613e64f362f5a5757beaf7f372a8268b2c312985 /libjava/Makefile.am
parentf669521ec15dd8b098c2277afe465f101b0c860b (diff)
downloadgcc-63f1781b2a21d39d7a502118469ae022f6a14c14.tar.gz
* Makefile.in: Rebuilt.
* Makefile.am (interpret.lo): New target. Add -fwrap to AM_CXXFLAGS. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@121299 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index 90e6afb24cf..60455958dd9 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -189,6 +189,9 @@ libgcj_la_SOURCES = prims.cc jni.cc jvmti.cc exception.cc stacktrace.cc \
link.cc defineclass.cc interpret.cc verify.cc \
$(nat_source_files)
+## We need to compile at least the interpreter this way.
+interpret.lo: AM_CXXFLAGS += -fwrapv
+
if USING_BOEHMGC
libgcj_la_SOURCES += boehm.cc
endif