summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>1999-05-12 11:23:44 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>1999-05-12 11:23:44 +0000
commit587322443e879045bb18f54cd82fc1dda215f3db (patch)
treeabd228e8accc8f1b67bdf10c59963d3a1cc6047f /libjava/Makefile.am
parent9808325da004f4924d728256add5035bd446a912 (diff)
downloadgcc-587322443e879045bb18f54cd82fc1dda215f3db.tar.gz
* include/javaprims.h: Updated namespace declarations.
* classes.pl (scan): Uniquify class list. * Makefile.in, configure: Rebuilt. * Makefile.am (nat_source_files): Added natConcreteProcess.cc. (built_java_source_files): New macro. (nat_headers): Added built_java_source_files. (javao_files): Likewise. (EXTRA_libgcj_la_SOURCES): Likewise. (libgcj.zip): Create built class files. ($(built_java_source_files:.java=.class)): New target. (jv_convert_LDADD): Added -L$(here)/.libs. * configure.in: Create links for ConcreteProcess.java and natConcreteProcess.cc. * java/lang/Runtime.java (exec): Create a ConcreteProcess. * java/lang/natEcosProcess.cc: New file. * java/lang/EcosProcess.java: New file. * java/lang/PosixProcess.java: New file. * java/lang/natPosixProcess.cc: New file. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@26901 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am28
1 files changed, 24 insertions, 4 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index 4a01079d8ba..82665dd7ba8 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -85,11 +85,12 @@ nat_files = $(nat_source_files:.cc=.lo)
## Objects from C sources in subdirs.
c_files = $(c_source_files:.c=.lo)
## Objects from Java sources in subdirs.
-javao_files = $(java_source_files:.java=.lo)
+javao_files = $(java_source_files:.java=.lo) \
+ $(built_java_source_files:.java=.lo)
libgcj_la_SOURCES = prims.cc jni.cc exception.cc
EXTRA_libgcj_la_SOURCES = boehm.cc nogc.cc posix-threads.cc no-threads.cc \
- $(c_source_files) $(java_source_files)
+ $(c_source_files) $(java_source_files) $(built_java_source_files)
libgcj_la_DEPENDENCIES = libgcj.zip $(javao_files) $(nat_files) \
$(c_files) $(GCOBJS) $(THREADOBJS)
libgcj_la_LIBADD = $(javao_files) $(nat_files) $(c_files) $(GCOBJS) \
@@ -106,6 +107,14 @@ libgcj_la_LDFLAGS = -rpath $(toolexeclibdir) \
## hand-maintained headers.
$(java_source_files:.java=.class): libgcj.zip
+## FIXME: this isn't really correct.
+$(built_java_source_files:.java=.class): $(built_java_source_files)
+## This little nastiness is here so that the backquoted stuff in the
+## GCJ definition can be correctly expanded, if required.
+ javac="$(JAVAC)"; \
+ $$javac $(JCFLAGS) -classpath $(here):`cd $(srcdir) && /bin/pwd` \
+ -d $(here) $?
+
## We have the zip file depend on the java sources and not the class
## files, because we don't know the names of all the class files.
## FIXME: this method fails in a peculiar case: if libgcj.zip is
@@ -113,6 +122,9 @@ $(java_source_files:.java=.class): libgcj.zip
## `make libgcj.zip' will not rebuilt foo.class. That's because
## libgcj.zip is not out-of-date with respect to foo.java.
libgcj.zip: $(java_source_files)
+## FIXME: this ought to depend on built_java_source_files, but right
+## now it can't. Ugly.
+ $(MAKE) $(built_java_source_files:.java=.class)
## This little nastiness is here so that the backquoted stuff in the
## GCJ definition can be correctly expanded, if required.
javac="$(JAVAC)"; cd $(srcdir); \
@@ -168,7 +180,8 @@ $(javao_files): %.lo: %.java
$(GCJH) -classpath $(top_builddir) $(basename $<)
## Header files used when compiling some of the nat* files.
-nat_headers = $(ordinary_java_source_files:.java=.h)
+nat_headers = $(ordinary_java_source_files:.java=.h) \
+ $(built_java_source_files:.java=.h)
$(nat_headers): libgcj.zip
@@ -268,8 +281,10 @@ jv_convert_LINK = $(LIBTOOL) --mode=link $(GCJ) $(JC1FLAGS) $(LDFLAGS) \
## We explicitly link in the libraries we need. This way we don't
## need -nodefaultlibs, so we can still rely on gcj picking up the
## system libraries we need (via the specs file).
+## We need the -L so that gcj can find libgcj with `-lgcj'.
+## FIXME: should be _libs on some systems.
jv_convert_LDADD = $(convert_source_files:.java=.lo) libgcj.la \
- $(GCLIBS) $(THREADLIBS) $(ZLIBS)
+ $(GCLIBS) $(THREADLIBS) $(ZLIBS) -L$(here)/.libs
## Depend on the spec file to make sure it is up to date before
## linking this program.
jv_convert_DEPENDENCIES = $(convert_source_files:.java=.lo) \
@@ -411,6 +426,10 @@ java/awt/peer/WindowPeer.java
# $(awt_java_source_files)
+## Java files which are created by configure and thus are in the build
+## directory.
+built_java_source_files = java/lang/ConcreteProcess.java
+
## List of all .java files to be compiled. Please keep this list
## alphabetical. Please put files from gnu/gcj/convert into
## convert_source_files. If the .java file has a hand-maintained
@@ -679,6 +698,7 @@ java/io/natFile.cc \
java/io/natFileDescriptor.cc \
java/lang/natCharacter.cc \
java/lang/natClass.cc \
+java/lang/natConcreteProcess.cc \
java/lang/natDouble.cc \
java/lang/natFirstThread.cc \
java/lang/natFloat.cc \