summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2000-04-26 17:29:05 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2000-04-26 17:29:05 +0000
commit0bcf33a2426a100408dabdb87dc3a1c8d04a7b12 (patch)
tree76c976564d69df2ec3d16f911bc26c34f2b76be3 /libjava/Makefile.am
parent1202e3922678520662e32b10472c3d3f37ac8a7a (diff)
downloadgcc-0bcf33a2426a100408dabdb87dc3a1c8d04a7b12.tar.gz
* Makefile.in: Rebuilt.
* Makefile.am (AM_CXXFLAGS): Added -fasynchronous-exceptions. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@33447 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index 7c2c0e2c7f6..7bbaede976c 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -80,8 +80,11 @@ EH_COMMON_INCLUDE = @EH_COMMON_INCLUDE@
WARNINGS = -W -Wall
## We need _GNU_SOURCE defined for some Linux builds. It doesn't hurt
## to always define it.
-AM_CXXFLAGS = -fno-rtti -fvtable-thunks @LIBGCJ_CXXFLAGS@ @EXCEPTIONSPEC@ \
- $(WARNINGS) -D_GNU_SOURCE
+## Note that we need -fasynchronous-exceptions because gcc is
+## currently broken with respect to exception handling in leaf
+## functions.
+AM_CXXFLAGS = -fno-rtti -fvtable-thunks -fasynchronous-exceptions \
+ @LIBGCJ_CXXFLAGS@ @EXCEPTIONSPEC@ $(WARNINGS) -D_GNU_SOURCE
if USING_GCC
AM_CFLAGS = @LIBGCJ_CFLAGS@ $(WARNINGS)
else