summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authorrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2008-03-16 06:57:40 +0000
committerrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2008-03-16 06:57:40 +0000
commit6a4431c9336526a6b81dd2fdfc72fb8bde0f69ea (patch)
treec16cd7efd9eb9c6a4f7ffbb5ed7adb2a9d45ff2a /libjava/Makefile.am
parente61456db1f1a35cc75cd1f291edce0ea1a66b3bd (diff)
downloadgcc-6a4431c9336526a6b81dd2fdfc72fb8bde0f69ea.tar.gz
libjava/
2008-03-16 Ralf Wildenhues <Ralf.Wildenhues@gmx.de> * Makefile.am (write_entries_to_file_split): New variable. (write_entries_to_file): Write out that many entries at once, for speed. * Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@133268 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index d840782d163..5b84c1769a7 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -13,13 +13,20 @@ SUBDIRS += testsuite
endif
# write_entries_to_file - writes each entry in a list
-# to the specified file. Each entry is written individually
-# to accomodate systems with severe command-line-length
-# limitations.
+# to the specified file. Entries are written in chunks of
+# $(write_entries_to_file_split) to accomodate systems with
+# severe command-line-length limitations.
# Parameters:
# $(1): variable containing entries to iterate over
# $(2): output file
-write_entries_to_file = $(shell rm -f $(2) || :) $(shell touch $(2)) $(foreach object,$(1),$(shell echo $(object) >> $(2)))
+write_entries_to_file_split = 50
+write_entries_to_file = $(shell rm -f $(2) || :) $(shell touch $(2)) \
+ $(foreach range, \
+ $(shell i=1; while test $$i -le $(words $(1)); do \
+ echo $$i; i=`expr $$i + $(write_entries_to_file_split)`; done), \
+ $(shell echo $(wordlist $(range), \
+ $(shell expr $(range) + $(write_entries_to_file_split) - 1), $(1)) \
+ | tr ' ' '\n' >> $(2)))
## ################################################################