summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authorgary <gary@138bc75d-0d04-0410-961f-82ee72b054a4>2006-11-03 10:16:04 +0000
committergary <gary@138bc75d-0d04-0410-961f-82ee72b054a4>2006-11-03 10:16:04 +0000
commitcf9498a89fd346d3e9989cb6480ebc495ef40345 (patch)
tree8a6600d7ecfed57029e5fe6bcacbb895c3ca5b97 /libjava/Makefile.am
parentd544e7d32e6c6901358ee5465a633aaf49690512 (diff)
downloadgcc-cf9498a89fd346d3e9989cb6480ebc495ef40345.tar.gz
2006-11-03 Gary Benson <gbenson@redhat.com>
* java/net/InetAddress.java: Removed. * java/net/natInetAddressNoNet.cc: Likewise. * java/net/natInetAddressPosix.cc: Likewise. * java/net/natInetAddressWin32.cc: Likewise. * java/net/VMInetAddress.java (getLocalHostname, lookupInaddrAny, getHostByAddr, getHostByName, aton): Replace glue methods with native ones. * java/net/natVMInetAddressNoNet.cc: New file. * java/net/natVMInetAddressPosix.cc: Likewise. * java/net/natVMInetAddressWin32.cc: Likewise. * Makefile.am, configure.ac: Reflect the above. * sources.am, Makefile.in, configure: Rebuilt. * java/net/natVMNetworkInterfaceWin32.cc (winsock2GetRealNetworkInterfaces): Create InetAddress objects using InetAddress.getByAddress. * gnu/java/net/natPlainSocketImplWin32.cc (accept, getOption): Likewise. * gnu/java/net/natPlainDatagramSocketImplWin32.cc (peekData, receive, getOption): Likewise. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@118451 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index a1c041a51b1..a0d6a3c9631 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -858,7 +858,7 @@ java/lang/reflect/natConstructor.cc \
java/lang/reflect/natField.cc \
java/lang/reflect/natMethod.cc \
java/net/natVMNetworkInterface.cc \
-java/net/natInetAddress.cc \
+java/net/natVMInetAddress.cc \
java/net/natURLClassLoader.cc \
java/nio/channels/natVMChannels.cc \
java/nio/natDirectByteBufferImpl.cc \