summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authorhjl <hjl@138bc75d-0d04-0410-961f-82ee72b054a4>2002-06-04 22:52:52 +0000
committerhjl <hjl@138bc75d-0d04-0410-961f-82ee72b054a4>2002-06-04 22:52:52 +0000
commit2bd747fcbb2c660fe12bf6653c6bb958a7d431d5 (patch)
tree1142ed5c982b4e6379dab5126a41ba99022ce9da /libjava/Makefile.am
parentae4cd3a56cd105520d8cc419d9f3b6316d1133fd (diff)
downloadgcc-2bd747fcbb2c660fe12bf6653c6bb958a7d431d5.tar.gz
2002-06-04 H.J. Lu (hjl@gnu.org)
* Makefile.am (libgcj_convenience.la): New target. (libgcj.la): Depend on libgcj_convenience.la. * Makefile.in: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@54268 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index a959fdbba5e..cfea0056475 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -222,10 +222,16 @@ $(javao_files) $(x_javao_files): %.lo: %.java
$(GCJCOMPILE) -o $@ $<
## Pass the list of object files to libtool in a temporary file to
-## avoid tripping platform command line length limits.
-libgcj.la: $(libgcj_la_OBJECTS) $(libgcj_la_DEPENDENCIES)
+## avoid tripping platform command line length limits. We also use
+# libgcj_convenience.la to avoid creating a long linker command line
+# which causes problems on some OSes and makes it almost impossible to
+# debug the linker under a debugger.
+libgcj_convenience.la: $(libgcj_la_OBJECTS) $(libgcj_la_DEPENDENCIES)
@: $(shell echo Creating list of files to link...) $(shell rm -f libgcj.objectlist || :) $(shell touch libgcj.objectlist) $(foreach object,$(libgcj_la_OBJECTS) $(libgcj_la_LIBADD),$(shell echo $(object) >> libgcj.objectlist))
- $(libgcj_la_LINK) -objectlist libgcj.objectlist \
+ $(libgcj_la_LINK) -objectlist libgcj.objectlist
+
+libgcj.la: libgcj_convenience.la
+ $(libgcj_la_LINK) libgcj_convenience.la \
@GCLIBS@ @LIBFFI@ @ZLIBS@ \
-rpath $(toolexeclibdir) $(libgcj_la_LDFLAGS) $(LIBS)