summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2002-04-16 15:52:26 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2002-04-16 15:52:26 +0000
commit9a7251071cd7dd07b48f8757846e059e486a1f31 (patch)
treea553b04ba6534c0fe8e96ce72c548a6a5a59f599 /libjava/Makefile.am
parent83cf4171d45f986748fdc3d50fd70424015625d1 (diff)
downloadgcc-9a7251071cd7dd07b48f8757846e059e486a1f31.tar.gz
Fix for PR libgcj/6081:
* Makefile.in: Rebuilt. * Makefile.am (install-data-local): Use GNU make trick to avoid shell limit. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@52370 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index 8e37339c2da..3caec30f672 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -349,13 +349,17 @@ $(extra_headers):
## hand.
install-data-local:
$(PRE_INSTALL)
- @for f in $(nat_headers) $(extra_headers); do \
+## We use a GNU make trick here so that we don't go over the command
+## length limit of some shells.
+ @: $(shell echo Creating list of headers to install...) $(shell rm -f tmp-ilist || :) $(shell touch tmp-ilist) $(foreach hdr,$(nat_headers) $(extra_headers),$(shell echo $(hdr) >> tmp-ilist))
+ @cat tmp-ilist | while read f; do \
d="`echo $$f | sed -e 's,/[^/]*$$,,'`"; \
$(mkinstalldirs) $(DESTDIR)$(includedir)/$$d; \
if test -f $(srcdir)/$$f; then p=$(srcdir)/$$f; else p=$$f; fi; \
echo " $(INSTALL_DATA) $$p $(DESTDIR)$(includedir)/$$f"; \
$(INSTALL_DATA) $$p $(DESTDIR)$(includedir)/$$f; \
done
+ -@rm -f tmp-ilist
## FIXME: the obvious approach using lib_DATA doesn't work with
## automake 1.4.
$(mkinstalldirs) $(DESTDIR)$(secdir)