summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authormembar <membar@138bc75d-0d04-0410-961f-82ee72b054a4>2007-02-10 14:17:58 +0000
committermembar <membar@138bc75d-0d04-0410-961f-82ee72b054a4>2007-02-10 14:17:58 +0000
commit3fba79901b40afafd501112eab8b2f711525b1ae (patch)
tree97dcafa20386547b5d3f4fbf71c1c848e42786da /libjava/Makefile.am
parent5814e0f6fae14c292627574cf2047c38b21ab563 (diff)
downloadgcc-3fba79901b40afafd501112eab8b2f711525b1ae.tar.gz
* Makefile.in: Rebuilt.
* Makefile.am (BUILD_ECJ1): Unify the command for renaming ecjx to the host's ecj1 executable. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@121796 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index 0e7d91a8042..9841f60c4af 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -454,12 +454,9 @@ if USE_LIBGCJ_BC
rm $(DESTDIR)$(toolexeclibdir)/libgcj_bc.la;
endif
if BUILD_ECJ1
-if NATIVE
+## Undo any prepending of the target prefix and transform
+## to the actual host's executable suffix.
mv $(DESTDIR)$(libexecsubdir)/`echo ecjx | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(libexecsubdir)/ecj1$(host_exeext)
-else !NATIVE
-## Undo the prepending of the target prefix
- mv $(DESTDIR)$(libexecsubdir)/$(target_noncanonical)-`echo ecjx | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(libexecsubdir)/ecj1$(host_exeext)
-endif !NATIVE
endif BUILD_ECJ1
## Install the headers. It is fairly ugly that we have to do this by