summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authorfitzsim <fitzsim@138bc75d-0d04-0410-961f-82ee72b054a4>2006-08-22 20:37:36 +0000
committerfitzsim <fitzsim@138bc75d-0d04-0410-961f-82ee72b054a4>2006-08-22 20:37:36 +0000
commit5a5c708ca485af170b08e32f7d612c1f084dcfd2 (patch)
treef54905dce8ace4179ad3874a31cb8155be9bb6df /libjava/Makefile.am
parentbf59186338bdd6827e4a38b7318a010e4905106c (diff)
downloadgcc-5a5c708ca485af170b08e32f7d612c1f084dcfd2.tar.gz
2006-08-22 Thomas Fitzsimmons <fitzsim@redhat.com>
PR libgcj/27890 * gnu/classpath/natSystemProperties.cc (insertSystemProperties): Set gnu.classpath.home.url to TOOLEXECLIBDIR. * configure.ac: Do not add --with-native-libdir to ac_configure_args. * java/security/libgcj.security: Remove file. * java/util/logging/logging.properties: Likewise. * classpath/m4/acinclude.m4 (CLASSPATH_TOOLEXECLIBDIR): New macro. * classpath/resource/Makefile.am (loggingdir): Define to toolexeclibdir. (securitydir): Likewise. * classpath/configure.ac: Call CLASSPATH_TOOLEXECLIBDIR. Set default nativeexeclibdir using toolexeclibdir. * HACKING: Fix classpath aclocal arguments. * Makefile.am (secdir): Remove variable. (propdir): Likewise. (AM_CXXFLAGS): Replace LIBDIR definition with TOOLEXECLIBDIR definition. (all_property_files): Remove variable. (install-data-local): Do not install libgcj.security or logging.properties. * configure, Makefile.in, classpath/configure, classpath/Makefile.in, classpath/native/jni/java-lang/Makefile.in, classpath/native/jni/midi-alsa/Makefile.in, classpath/native/jni/classpath/Makefile.in, classpath/native/jni/midi-dssi/Makefile.in, classpath/native/jni/Makefile.in, classpath/native/jni/java-nio/Makefile.in, classpath/native/jni/java-net/Makefile.in, classpath/native/jni/gconf-peer/Makefile.in, classpath/native/jni/java-io/Makefile.in, classpath/native/jni/xmlj/Makefile.in, classpath/native/jni/java-util/Makefile.in, classpath/native/jni/qt-peer/Makefile.in, classpath/native/jni/gtk-peer/Makefile.in, classpath/native/Makefile.in, classpath/native/jawt/Makefile.in, classpath/native/target/Linux/Makefile.in, classpath/native/target/Makefile.in, classpath/native/target/generic/Makefile.in, classpath/native/fdlibm/Makefile.in, classpath/native/plugin/Makefile.in, classpath/resource/Makefile.in, classpath/scripts/Makefile.in, classpath/tools/Makefile.in, classpath/doc/Makefile.in, classpath/doc/api/Makefile.in, classpath/lib/Makefile.in, classpath/external/Makefile.in, classpath/external/sax/Makefile.in, classpath/external/w3c_dom/Makefile.in, classpath/external/relaxngDatatype/Makefile.in, classpath/include/Makefile.in, classpath/aclocal.m4, classpath/examples/Makefile.in, aclocal.m4: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@116332 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am18
1 files changed, 1 insertions, 17 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index 85e6fec94df..25bfe6515e7 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -60,11 +60,6 @@ JAVA_HOME_DIR = $(prefix)
BOOT_CLASS_PATH_DIR = $(jardir)/libgcj-$(gcc_version).jar
endif
-## FIXME: Using libdir violates GNU coding standards.
-secdir = $(libdir)/security
-## Where to install default logging property file.
-propdir = $(libdir)
-
## Name of the default .db.
db_name = classmap.db
## Compiler specific component of the .db file
@@ -124,7 +119,7 @@ AM_CXXFLAGS = \
$(WARNINGS) \
-D_GNU_SOURCE \
-DPREFIX="\"$(prefix)\"" \
- -DLIBDIR="\"$(libdir)\"" \
+ -DTOOLEXECLIBDIR="\"$(toolexeclibdir)\"" \
-DJAVA_HOME="\"$(JAVA_HOME_DIR)\"" \
-DBOOT_CLASS_PATH="\"$(BOOT_CLASS_PATH_DIR)\"" \
-DJAVA_EXT_DIRS="\"$(jardir)/ext\"" \
@@ -166,9 +161,6 @@ BOOTCLASSPATH = $(here)/classpath/lib
## ################################################################
-all_property_files = $(property_files) \
- java/util/logging/logging.properties
-
##
## How to build libgcj.a and libgcj.jar
##
@@ -568,14 +560,6 @@ install-data-local:
$(INSTALL_DATA) $$p $(DESTDIR)$(gxx_include_dir)/$$f; \
done
-@rm -f tmp-ilist
-## FIXME: the obvious approach using lib_DATA doesn't work with
-## automake 1.4.
- $(mkinstalldirs) $(DESTDIR)$(secdir)
- @for f in libgcj.security; do \
- echo " $(INSTALL_DATA) $(srcdir)/java/security/$$f $(DESTDIR)$(secdir)/$$f"; \
- $(INSTALL_DATA) $(srcdir)/java/security/$$f $(DESTDIR)$(secdir)/$$f; \
- done
- $(INSTALL_DATA) $(srcdir)/java/util/logging/logging.properties $(DESTDIR)$(propdir)/logging.properties
## Install inner class headers.
$(INSTALL_DATA) 'java/io/ObjectOutputStream$$PutField.h' $(DESTDIR)$(gxx_include_dir)/java/io/
$(INSTALL_DATA) 'java/io/ObjectInputStream$$GetField.h' $(DESTDIR)$(gxx_include_dir)/java/io/