summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>1999-06-21 13:03:47 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>1999-06-21 13:03:47 +0000
commitc34aeb9d18d45fd59b972838c9dbd41b6d434d34 (patch)
tree3eb065174a652092763e1549b98f6df22f1939c4 /libjava/Makefile.am
parent5c4e04548894fcf7ec535bfa4407dbe610a7a6cf (diff)
downloadgcc-c34aeb9d18d45fd59b972838c9dbd41b6d434d34.tar.gz
* Makefile.in: Rebuilt.
* Makefile.am (toolexeclibdir): Define as libdir when appropriate. * configure: Rebuilt. * configure.in (USE_LIBDIR): New conditional. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@27667 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index 687f831527e..067f49bf6a5 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -12,8 +12,14 @@ endif
## What gets installed, and where.
##
+## Install a library built with a cross compiler in tooldir, not
+## libdir.
+if USE_LIBDIR
+toolexeclibdir = $(libdir)
+else
toolexecdir = $(exec_prefix)/$(target_alias)
toolexeclibdir = $(toolexecdir)/lib$(MULTISUBDIR)
+endif
toolexeclib_LTLIBRARIES = libgcj.la
toolexeclib_DATA = libgcj.spec