summaryrefslogtreecommitdiff
path: root/libjava/configure.ac
diff options
context:
space:
mode:
authorro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2010-05-25 16:59:45 +0000
committerro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2010-05-25 16:59:45 +0000
commit4baad003eb4756473339a1f11a036e4adb9f7454 (patch)
tree5c065c5b5ddaca208481e58ce228f3f42df64e19 /libjava/configure.ac
parentaa3d8448c54ad0617c50e8a42b3e9627b3b1ef3f (diff)
downloadgcc-4baad003eb4756473339a1f11a036e4adb9f7454.tar.gz
PR libgcj/44216
* configure.ac (libgcj_cv_exidx): Enable AC_LANG_WERROR. Save and restore werror flag. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@159833 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.ac')
-rw-r--r--libjava/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/libjava/configure.ac b/libjava/configure.ac
index 664011ea6cb..5376a0157ea 100644
--- a/libjava/configure.ac
+++ b/libjava/configure.ac
@@ -932,9 +932,17 @@ esac
AC_CACHE_CHECK([for --no-merge-exidx-entries], [libgcj_cv_exidx],
[saved_ldflags="$LDFLAGS"
LDFLAGS="${LDFLAGS} -Wl,--no-merge-exidx-entries"
+ # The IRIX 6 ld doesn't recognize --no-merge-exidx-entries, but only
+ # warns about unknown options, which breaks the testsuite. So enable
+ # AC_LANG_WERROR, but there's currently (autoconf 2.64) no way to turn
+ # it off again. As a workaround, save and restore werror flag like
+ # AC_PATH_XTRA.
+ ac_xsave_[]_AC_LANG_ABBREV[]_werror_flag=$ac_[]_AC_LANG_ABBREV[]_werror_flag
+ AC_LANG_WERROR
AC_LINK_IFELSE([int main(void){ return 0;} ],
[eval "libgcj_cv_exidx=yes"],
[eval "libgcj_cv_exidx=no"])
+ ac_[]_AC_LANG_ABBREV[]_werror_flag=$ac_xsave_[]_AC_LANG_ABBREV[]_werror_flag
LDFLAGS="${saved_ldflags}"]
)
if test "${libgcj_cv_exidx}" = "yes"; then