summaryrefslogtreecommitdiff
path: root/libjava/configure.ac
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2005-02-08 21:51:34 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2005-02-08 21:51:34 +0000
commitb1ecf63da20058f89a2e7d23e14581e5d946d0b1 (patch)
treeb55c998eb2051c85431967ad6c3496032ba6f708 /libjava/configure.ac
parent9e71f2c8440bfd3d6ffc9d44b730abe1fb8b6434 (diff)
downloadgcc-b1ecf63da20058f89a2e7d23e14581e5d946d0b1.tar.gz
* configure: Rebuilt.
* configure.ac: Reduce number of calls to AC_CHECK_FUNCS and AC_CHECK_HEADERS. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@94748 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.ac')
-rw-r--r--libjava/configure.ac19
1 files changed, 11 insertions, 8 deletions
diff --git a/libjava/configure.ac b/libjava/configure.ac
index 292578547c1..d2f1c1058fa 100644
--- a/libjava/configure.ac
+++ b/libjava/configure.ac
@@ -759,13 +759,13 @@ if test "x${with_newlib}" = "xyes"; then
AC_DEFINE(NO_GETUID, 1, [Define if getuid() and friends are missing.])
PLATFORMNET=NoNet
else
- AC_CHECK_FUNCS(strerror ioctl select fstat open fsync sleep opendir)
- AC_CHECK_FUNCS(gmtime_r localtime_r readdir_r getpwuid_r getcwd)
- AC_CHECK_FUNCS(access stat mkdir rename rmdir unlink realpath utime chmod)
- AC_CHECK_FUNCS(nl_langinfo setlocale)
+ AC_CHECK_FUNCS([strerror ioctl select fstat open fsync sleep opendir \
+ gmtime_r localtime_r readdir_r getpwuid_r getcwd \
+ access stat mkdir rename rmdir unlink realpath utime chmod \
+ nl_langinfo setlocale \
+ inet_pton uname inet_ntoa \
+ fork execvp pipe sigaction ftruncate])
AC_CHECK_FUNCS(inet_aton inet_addr, break)
- AC_CHECK_FUNCS(inet_pton uname inet_ntoa)
- AC_CHECK_FUNCS(fork execvp pipe sigaction ftruncate)
AC_CHECK_HEADERS(execinfo.h unistd.h dlfcn.h)
AC_CHECK_FUNC(backtrace, [
case "$host" in
@@ -1207,10 +1207,13 @@ TL_AC_GXX_INCLUDE_DIR
# We check for sys/filio.h because Solaris 2.5 defines FIONREAD there.
# On that system, sys/ioctl.h will not include sys/filio.h unless
# BSD_COMP is defined; just including sys/filio.h is simpler.
-AC_CHECK_HEADERS(unistd.h bstring.h sys/time.h sys/types.h fcntl.h sys/ioctl.h sys/filio.h sys/stat.h sys/select.h sys/socket.h netinet/in.h arpa/inet.h netdb.h net/if.h pwd.h sys/config.h stdint.h langinfo.h locale.h)
# We avoid AC_HEADER_DIRENT since we really only care about dirent.h
# for now. If you change this, you also must update natFile.cc.
-AC_CHECK_HEADERS(dirent.h)
+AC_CHECK_HEADERS([unistd.h bstring.h sys/time.h sys/types.h fcntl.h \
+ sys/ioctl.h sys/filio.h sys/stat.h sys/select.h \
+ sys/socket.h netinet/in.h arpa/inet.h netdb.h net/if.h \
+ pwd.h sys/config.h stdint.h langinfo.h locale.h \
+ dirent.h])
AC_CHECK_HEADERS(inttypes.h, [
AC_DEFINE(HAVE_INTTYPES_H, 1, [Define if <inttypes.h> is available])
AC_DEFINE(JV_HAVE_INTTYPES_H, 1, [Define if <inttypes.h> is available])