summaryrefslogtreecommitdiff
path: root/libjava/configure.ac
diff options
context:
space:
mode:
authorandreast <andreast@138bc75d-0d04-0410-961f-82ee72b054a4>2006-05-20 21:33:07 +0000
committerandreast <andreast@138bc75d-0d04-0410-961f-82ee72b054a4>2006-05-20 21:33:07 +0000
commit775ffa8d8ecfe6a5d7ec56ec22335628a429f764 (patch)
treee6125a2ca63cd08037fda672d2a0a2a74790314b /libjava/configure.ac
parent7e7dbd38e6cf03e7b5dc381021e4b6bdc7aa8eeb (diff)
downloadgcc-775ffa8d8ecfe6a5d7ec56ec22335628a429f764.tar.gz
2006-05-20 Andreas Tobler <a.tobler@schweiz.ch>
John David Anglin <dave.anglin@nrc-cnrc.gc.ca> * configure.ac: Add the POSIX thread libs to the HP-UX PA configuration. Add signal specification for HP-UX PA. * configure: Rebuilt. * configure.host: Add defaults for the HP-UX PA architecture. Add descriptor files for HP-UX PA 32-bit and 64-bit. * include/hppa-signal.h: New file. * include/posix.h: Add shared library suffix for HP-UX. * sysdep/pa/descriptor-pa32-hpux.h: New file. * sysdep/pa/descriptor-pa64-hpux.h: Likewise. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@113937 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.ac')
-rw-r--r--libjava/configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/libjava/configure.ac b/libjava/configure.ac
index 69f43174b1c..6b9797912e2 100644
--- a/libjava/configure.ac
+++ b/libjava/configure.ac
@@ -805,7 +805,7 @@ case "$THREADS" in
THREADLDFLAGS=-pthread
THREADSPEC=-lpthread
;;
- alpha*-dec-osf*)
+ alpha*-dec-osf* | hppa*-hp-hpux*)
THREADCXXFLAGS=-pthread
# boehm-gc needs some functions from librt, so link that too.
THREADLIBS='-lpthread -lrt'
@@ -1371,6 +1371,9 @@ case "${host}" in
hppa*-*-linux*)
SIGNAL_HANDLER=include/pa-signal.h
;;
+ hppa*-hp-hpux*)
+ SIGNAL_HANDLER=include/hppa-signal.h
+ ;;
ia64-*-linux*)
SIGNAL_HANDLER=include/dwarf2-signal.h
;;