summaryrefslogtreecommitdiff
path: root/libjava/configure.ac
diff options
context:
space:
mode:
authorzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2005-03-21 18:12:32 +0000
committerzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2005-03-21 18:12:32 +0000
commitdbff38f9ca9b48a7462feade10bc000d510206ae (patch)
treeb529223225cfa13fe07018548450763b2a152593 /libjava/configure.ac
parent7d0f7bf8796f6f2af3eb54c527ac5714fe193883 (diff)
downloadgcc-dbff38f9ca9b48a7462feade10bc000d510206ae.tar.gz
config:
* gxx-include-dir.m4: In all substitutions, leave $(gcc_version) to be expanded by the Makefile. libjava: * configure.ac: Do not invoke TL_AC_GCC_VERSION. Do not set tool_include_dir. In all substitutions, leave $(gcc_version) to be expanded by the Makefile. * aclocal.m4, configure: Regenerate. * Makefile.am: Set gcc_version. Replace all uses of @gcc_version@ with $(gcc_version). * external/Makefile.am, external/sax/Makefile.am * external/w3c_dom/Makefile.am, gcj/Makefile.am * testsuite/Makefile.am: Set gcc_version. * include/Makefile.am: Set gcc_version and tool_include_dir. * Makefile.in, external/Makefile.in, external/sax/Makefile.in * external/w3c_dom/Makefile.in, gcj/Makefile.in, include/Makefile.in * testsuite/Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@96825 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.ac')
-rw-r--r--libjava/configure.ac11
1 files changed, 2 insertions, 9 deletions
diff --git a/libjava/configure.ac b/libjava/configure.ac
index 2e40268038a..8366523de90 100644
--- a/libjava/configure.ac
+++ b/libjava/configure.ac
@@ -720,18 +720,11 @@ if test "$enable_hash_synchronization" = yes && test "$THREADS" != "none"; then
fi
AC_SUBST(HASH_SYNC_SPEC)
-
AM_CONDITIONAL(USING_GCC, test "$GCC" = yes)
# We're in the tree with gcc, and need to include some of its headers.
GCC_UNWIND_INCLUDE='-I$(libgcj_basedir)/../gcc'
-TL_AC_GCC_VERSION([$srcdir/..])
-
-# Figure out where generated headers like libgcj-config.h get installed.
-tool_include_dir='$(libdir)/gcc/$(target_noncanonical)/'${gcc_version}/include
-AC_SUBST(tool_include_dir)
-
if test "x${with_newlib}" = "xyes"; then
# We are being configured with a cross compiler. AC_REPLACE_FUNCS
# may not work correctly, because the compiler may not be able to
@@ -1171,9 +1164,9 @@ case ${version_specific_libs} in
# Need the gcc compiler version to know where to install libraries
# and header files if --enable-version-specific-runtime-libs option
# is selected.
- includedir='${libdir}/gcc/${target_noncanonical}/'$gcc_version/include/
+ includedir='$(libdir)/gcc/$(target_noncanonical)/$(gcc_version)/include/'
toolexecdir='$(libdir)/gcc/$(target_noncanonical)'
- toolexecmainlibdir='$(toolexecdir)/'${gcc_version}'$(MULTISUBDIR)'
+ toolexecmainlibdir='$(toolexecdir)/$(gcc_version)$(MULTISUBDIR)'
toolexeclibdir=$toolexecmainlibdir
;;
no)