summaryrefslogtreecommitdiff
path: root/libjava/configure.in
diff options
context:
space:
mode:
authorgreen <green@138bc75d-0d04-0410-961f-82ee72b054a4>2000-01-09 22:25:54 +0000
committergreen <green@138bc75d-0d04-0410-961f-82ee72b054a4>2000-01-09 22:25:54 +0000
commitc843840fa3eb6f283bffaaed942c9243047ea10b (patch)
tree643466db439a80706c0651653ca6f845432f490d /libjava/configure.in
parentb8f617cc83c2bdc34c7f73664f18f1bd562af225 (diff)
downloadgcc-c843840fa3eb6f283bffaaed942c9243047ea10b.tar.gz
2000-01-09 Anthony Green <green@cygnus.com>
* java/lang/natString.cc (init): Test for overflow condition during out of bounds check. (getChars): Throw StringIndexOutOfBoundsException, not ArrayIndexOutOfBoundsException. (getBytes): Ditto. (regionMatches): Obey case option during string comparison. * configure.host (ligcj_interpreter): New variable. Enable interpreter by default on IA-32. * configure.in: Examine libgcj_interpreter. * configure: Rebuilt. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@31300 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.in')
-rw-r--r--libjava/configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/libjava/configure.in b/libjava/configure.in
index 519ffb585a9..080146ae716 100644
--- a/libjava/configure.in
+++ b/libjava/configure.in
@@ -61,9 +61,14 @@ dnl See if the user has the interpreter included.
AC_ARG_ENABLE(interpreter,
[ --enable-interpreter enable interpreter],
if test "$enable_interpreter" = yes; then
- AC_DEFINE(INTERPRETER)
+ # This can also be set in configure.host.
+ libgcj_interpreter=yes
fi)
+if test "$libgcj_interpreter" = yes; then
+ AC_DEFINE(INTERPRETER)
+fi
+
EXCEPTIONSPEC=
dnl See if we should use setjmp/longjmp exceptions
AC_ARG_ENABLE(sjlj-exceptions,