summaryrefslogtreecommitdiff
path: root/libjava/configure.in
diff options
context:
space:
mode:
authorbryce <bryce@138bc75d-0d04-0410-961f-82ee72b054a4>2001-04-01 11:16:40 +0000
committerbryce <bryce@138bc75d-0d04-0410-961f-82ee72b054a4>2001-04-01 11:16:40 +0000
commit13487a5ef4e62b2ad9a1836e7826c648d61b26b3 (patch)
tree64ffcb42dcabba681035f83df8bad41e16ad89de /libjava/configure.in
parent7bba3a77d979f58524f736cd310a740af5dd1236 (diff)
downloadgcc-13487a5ef4e62b2ad9a1836e7826c648d61b26b3.tar.gz
1.3-Compliant Implementation of java.io.File.
* java/lang/natSystem.cc (init_properties): Get "file.separator", "path.separator", and "java.io.tmpdir" from the File class, instead of setting them explicitly. * java/io/File.java: Do not canonicalize paths for security manager checks. Call init_native() from static initializer. Do not pass path argument to native methods. New native method declarations. Some security manager checks moved to checkWrite(). (equals): Check file system case sensitivity and act appropriatly. (hashCode): Likewise. (isHidden): New method implemented. (performList): Changed prototype. Now takes a class argument specifying the class of the returned array: Strings or File objects. Also added FileFilter argument. (listFiles): New variants with "File" return type implemented. (createTempFile): Use createNewFile(). Use maxPathLen. (setReadOnly): New method implemented. (listRoots): Likewise. (compareTo): Likewise. (setLastModified): Likewise. (checkWrite): New method. (setPath): Removed. * java/io/natFile.cc: Various functions no longer take canonical path argument. (stat): Handle ISHIDDEN query. (isAbsolute): Remove WIN32 cruft. (performList): New arguments. Handle returning either File[] or String[] arrays. Check with FileFilter or FilenameFilter arguments as appropriate. Use an ArrayList, not a Vector, for the temporary list. (performSetReadOnly): New method implemented. (performListRoots): Likewise. (performSetLastModified): Likewise. (performCreate): Likewise. (init_native): New initialization function. * java/io/natFileWin32.cc: Various functions no longer take canonical path argument. (stat): Add FIXME about ISHIDDEN query. (performList): New arguments. Handle returning either File[] or String[] arrays. Check with FileFilter or FilenameFilter arguments as appropriate. Use an ArrayList, not a Vector, for the temporary list. (performSetReadOnly): New. Stubbed. (performListRoots): Likewise. (performSetLastModified): Likewise. (performCreate): Likewise. (init_native) New initialization function. * configure.in: Check for utime() and chmod(). * configure: Rebuilt. * include/config.h.in: Rebuilt. Resolves PR libgcj/1759. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@40985 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.in')
-rw-r--r--libjava/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/libjava/configure.in b/libjava/configure.in
index 89bbe7fb198..4e00fce4ac0 100644
--- a/libjava/configure.in
+++ b/libjava/configure.in
@@ -431,7 +431,7 @@ if test -n "${with_cross_host}"; then
else
AC_CHECK_FUNCS(strerror ioctl select fstat open fsync sleep)
AC_CHECK_FUNCS(gmtime_r localtime_r readdir_r getpwuid_r getcwd)
- AC_CHECK_FUNCS(access stat mkdir rename rmdir unlink realpath)
+ AC_CHECK_FUNCS(access stat mkdir rename rmdir unlink realpath utime chmod)
AC_CHECK_FUNCS(iconv nl_langinfo setlocale)
AC_CHECK_FUNCS(inet_aton inet_addr, break)
AC_CHECK_FUNCS(inet_pton uname inet_ntoa)
@@ -669,6 +669,7 @@ changequote(<<,>>)
gcjvers="`$GCJ -v 2>&1 | sed -n 's/^.*version \([^ ]*\).*$/\1/p'`"
changequote([,])
AC_DEFINE_UNQUOTED(GCJVERSION, "$gcjvers")
+AC_SUBST(GCJVERSION)
AC_SUBST(AM_RUNTESTFLAGS)