summaryrefslogtreecommitdiff
path: root/libmudflap/Makefile.am
diff options
context:
space:
mode:
authorfche <fche@138bc75d-0d04-0410-961f-82ee72b054a4>2006-06-21 16:35:27 +0000
committerfche <fche@138bc75d-0d04-0410-961f-82ee72b054a4>2006-06-21 16:35:27 +0000
commit47cd9fb8868a022deb280e79914ed833abe348ee (patch)
tree1207e8d24c96fe13484c89793d936f45b8d8e690 /libmudflap/Makefile.am
parent6f7c035731a3b7276254e248af4d468fecca80fb (diff)
downloadgcc-47cd9fb8868a022deb280e79914ed833abe348ee.tar.gz
2006-06-21 Frank Ch. Eigler <fche@redhat.com>
PR 21274 mf-runtime.h installation based on ssp patch for PR 26473 from Mark Mitchell <mark@codesourcery.com>. * configure.ac (ACX_NONCANONICAL_TARGET): Use it. * Makefile.am (target_noncanonical): Define. (libsubincludedir): New variable. (nobase_libsubinclude_HEADERS): Add mf-runtime.h. (include_HEADERS): Remove. * configure, aclocal.m4, config.h.in: Regenerated. * Makefile.in, testsuite/Makefile.in: Likewise. * mf-runtime.h: Add #ifndef protection for conflicting _REENTRANT and _THREAD_SAFE redefinition values. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@114855 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libmudflap/Makefile.am')
-rw-r--r--libmudflap/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/libmudflap/Makefile.am b/libmudflap/Makefile.am
index 5db952414d7..8575da272be 100644
--- a/libmudflap/Makefile.am
+++ b/libmudflap/Makefile.am
@@ -22,7 +22,9 @@ libmudflapth =
endif
toolexeclib_LTLIBRARIES = libmudflap.la $(libmudflapth)
-include_HEADERS = mf-runtime.h
+target_noncanonical = @target_noncanonical@
+libsubincludedir = $(libdir)/gcc/$(target_noncanonical)/$(gcc_version)/include
+nobase_libsubinclude_HEADERS = mf-runtime.h
libmudflap_la_SOURCES = \