summaryrefslogtreecommitdiff
path: root/libmudflap/configure.ac
diff options
context:
space:
mode:
authorfche <fche@138bc75d-0d04-0410-961f-82ee72b054a4>2006-06-21 16:35:27 +0000
committerfche <fche@138bc75d-0d04-0410-961f-82ee72b054a4>2006-06-21 16:35:27 +0000
commit47cd9fb8868a022deb280e79914ed833abe348ee (patch)
tree1207e8d24c96fe13484c89793d936f45b8d8e690 /libmudflap/configure.ac
parent6f7c035731a3b7276254e248af4d468fecca80fb (diff)
downloadgcc-47cd9fb8868a022deb280e79914ed833abe348ee.tar.gz
2006-06-21 Frank Ch. Eigler <fche@redhat.com>
PR 21274 mf-runtime.h installation based on ssp patch for PR 26473 from Mark Mitchell <mark@codesourcery.com>. * configure.ac (ACX_NONCANONICAL_TARGET): Use it. * Makefile.am (target_noncanonical): Define. (libsubincludedir): New variable. (nobase_libsubinclude_HEADERS): Add mf-runtime.h. (include_HEADERS): Remove. * configure, aclocal.m4, config.h.in: Regenerated. * Makefile.in, testsuite/Makefile.in: Likewise. * mf-runtime.h: Add #ifndef protection for conflicting _REENTRANT and _THREAD_SAFE redefinition values. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@114855 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libmudflap/configure.ac')
-rw-r--r--libmudflap/configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/libmudflap/configure.ac b/libmudflap/configure.ac
index 51ed6e3bf4a..ff356f2603c 100644
--- a/libmudflap/configure.ac
+++ b/libmudflap/configure.ac
@@ -1,10 +1,11 @@
# Process this file with autoconf to produce a configure script, like so:
-# aclocal && autoconf && autoheader && automake
+# aclocal -I .. -I ../config && autoconf && autoheader && automake
AC_PREREQ(2.59)
AC_INIT(libmudflap, 1.0)
AC_CONFIG_SRCDIR(mf-runtime.c)
AC_CANONICAL_SYSTEM
+ACX_NONCANONICAL_TARGET
AM_INIT_AUTOMAKE
@@ -175,6 +176,9 @@ esac
AC_SUBST(toolexecdir)
AC_SUBST(toolexeclibdir)
+includedir=${toolexecdir}/include
+AC_SUBST(includedir)
+
pthread_create_version='""'
if test "x$enable_shared" = "xyes" && test "x$posix_threads" != "x"; then
# NB: don't check for -lpthread here, because then it would be