summaryrefslogtreecommitdiff
path: root/libobjc/configure.in
diff options
context:
space:
mode:
authorneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-04-09 12:24:52 +0000
committerneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-04-09 12:24:52 +0000
commit109c38446e4ed2a42e9127101a62b1150108421e (patch)
treecbf2decb66d792c18ebd79a4005c1d885b4aeaa5 /libobjc/configure.in
parentaaa34aa07d4dbae1bcef69f50f410acdaf2d70da (diff)
downloadgcc-109c38446e4ed2a42e9127101a62b1150108421e.tar.gz
* configure.in: Replace old AC_PROG_CC hack with new one.
Define toplevel_srcdir in terms of srcdir, not top_srcdir (there are no subdirectory output files, so this is fine). Change prereq to autoconf 2.59. * aclocal.m4: Include ../config/no-executables.m4. * configure: Regenerate with autoconf 2.59. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@80549 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libobjc/configure.in')
-rw-r--r--libobjc/configure.in57
1 files changed, 4 insertions, 53 deletions
diff --git a/libobjc/configure.in b/libobjc/configure.in
index 040976d2290..beb02293d9c 100644
--- a/libobjc/configure.in
+++ b/libobjc/configure.in
@@ -20,7 +20,7 @@
#the Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
#02111-1307, USA.
-AC_PREREQ(2.13)
+AC_PREREQ(2.59)
AC_INIT(objc/objc.h)
AC_CONFIG_HEADER(config.h)
@@ -64,7 +64,7 @@ else
toprel=".."
fi
AC_CONFIG_AUX_DIR(${srcdir}/$toprel)
-toplevel_srcdir=\${top_srcdir}/$toprel
+toplevel_srcdir=\${srcdir}/$toprel
AC_SUBST(toplevel_srcdir)
AC_CANONICAL_SYSTEM
@@ -90,63 +90,14 @@ AC_ARG_WITH(target-subdir,
AC_ARG_WITH(cross-host,
[ --with-cross-host=HOST configuring with a cross compiler])
- # Never versions of autoconf add an underscore to these functions.
- # Prevent future problems ...
- ifdef([AC_PROG_CC_G],[],[define([AC_PROG_CC_G],defn([_AC_PROG_CC_G]))])
- ifdef([AC_PROG_CC_GNU],[],[define([AC_PROG_CC_GNU],defn([_AC_PROG_CC_GNU]))])
- ifdef([AC_PROG_CXX_G],[],[define([AC_PROG_CXX_G],defn([_AC_PROG_CXX_G]))])
- ifdef([AC_PROG_CXX_GNU],[],[define([AC_PROG_CXX_GNU],defn([_AC_PROG_CXX_GNU]))])
-
-# AC_PROG_CC
-
-# FIXME: We temporarily define our own version of AC_PROG_CC. This is
-# copied from autoconf 2.12, but does not call AC_PROG_CC_WORKS. We
-# are probably using a cross compiler, which will not be able to fully
-# link an executable. This should really be fixed in autoconf
-# itself.
-
-AC_DEFUN(LIB_AC_PROG_CC,
-[AC_BEFORE([$0], [AC_PROG_CPP])dnl
-dnl Fool anybody using AC_PROG_CC.
-AC_PROVIDE([AC_PROG_CC])
-AC_CHECK_PROG(CC, gcc, gcc)
-if test -z "$CC"; then
- AC_CHECK_PROG(CC, cc, cc, , , /usr/ucb/cc)
- test -z "$CC" && AC_MSG_ERROR([no acceptable cc found in \$PATH])
-fi
-
-AC_PROG_CC_GNU
-
-if test $ac_cv_prog_gcc = yes; then
- GCC=yes
-dnl Check whether -g works, even if CFLAGS is set, in case the package
-dnl plays around with CFLAGS (such as to build both debugging and
-dnl normal versions of a library), tasteless as that idea is.
- ac_test_CFLAGS="${CFLAGS+set}"
- ac_save_CFLAGS="$CFLAGS"
- CFLAGS=
- AC_PROG_CC_G
- if test "$ac_test_CFLAGS" = set; then
- CFLAGS="$ac_save_CFLAGS"
- elif test $ac_cv_prog_cc_g = yes; then
- CFLAGS="-g -O2"
- else
- CFLAGS="-O2"
- fi
-else
- GCC=
- test "${CFLAGS+set}" = set || CFLAGS="-g"
-fi
-])
-
-LIB_AC_PROG_CC
+GCC_NO_EXECUTABLES
+AC_PROG_CC
AC_CHECK_TOOL(AS, as)
AC_CHECK_TOOL(AR, ar)
AC_CHECK_TOOL(RANLIB, ranlib, :)
AC_PROG_INSTALL
-
# Process the option "--enable-version-specific-runtime-libs"
AC_MSG_CHECKING([for --enable-version-specific-runtime-libs])
AC_ARG_ENABLE(version-specific-runtime-libs,