summaryrefslogtreecommitdiff
path: root/libquadmath/Makefile.am
diff options
context:
space:
mode:
authorTobias Burnus <burnus@net-b.de>2010-12-08 09:06:49 +0100
committerTobias Burnus <burnus@gcc.gnu.org>2010-12-08 09:06:49 +0100
commit4c993c44a094c023d70b6548955ebfef9b8e8721 (patch)
tree2b1ed8c40ac9bc96e92cf0633b01f6ea4c4a5e23 /libquadmath/Makefile.am
parent505b439a062e6f264161f33c0c50727d5614b28b (diff)
downloadgcc-4c993c44a094c023d70b6548955ebfef9b8e8721.tar.gz
re PR fortran/46543 (libquadmath: Add documentation)
2010-12-08 Tobias Burnus <burnus@net-b.de> PR fortran/46543 * configure.ac: Add texinfo checks. * Makefile.am: Handle .texi documentation. * libquadmath.texi: New. * configure: Regenerated. * Makefile.in: Regenerated. From-SVN: r167583
Diffstat (limited to 'libquadmath/Makefile.am')
-rw-r--r--libquadmath/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/libquadmath/Makefile.am b/libquadmath/Makefile.am
index c1f0b638d55..e9071237755 100644
--- a/libquadmath/Makefile.am
+++ b/libquadmath/Makefile.am
@@ -105,4 +105,46 @@ AM_MAKEFLAGS = \
MAKEOVERRIDES=
+# AM_CONDITIONAL on configure option --generated-files-in-srcdir
+if GENINSRC
+STAMP_GENINSRC = stamp-geninsrc
+else
+STAMP_GENINSRC =
+endif
+
+# AM_CONDITIONAL on configure check ACX_CHECK_PROG_VER([MAKEINFO])
+if BUILD_INFO
+STAMP_BUILD_INFO = stamp-build-info
+else
+STAMP_BUILD_INFO =
endif
+
+
+all-local: $(STAMP_GENINSRC)
+
+stamp-geninsrc: libquadmath.info
+ cp -p $(top_builddir)/libquadmath.info $(srcdir)/libquadmath.info
+ @touch $@
+
+libquadmath.info: $(STAMP_BUILD_INFO)
+
+stamp-build-info: libquadmath.texi
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -o libquadmath.info $(srcdir)/libquadmath.texi
+ @touch $@
+
+CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) libquadmath.info
+MAINTAINERCLEANFILES = $(srcdir)/libquadmath.info
+
+endif
+
+
+# Automake Documentation:
+# If your package has Texinfo files in many directories, you can use the
+# variable TEXINFO_TEX to tell Automake where to find the canonical
+# `texinfo.tex' for your package. The value of this variable should be
+# the relative path from the current `Makefile.am' to `texinfo.tex'.
+TEXINFO_TEX = ../gcc/doc/include/texinfo.tex
+
+# Defines info, dvi, pdf and html targets
+MAKEINFOFLAGS = -I $(srcdir)/../gcc/doc/include
+info_TEXINFOS = libquadmath.texi