summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2009-01-15 20:02:11 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2009-01-15 20:02:11 +0000
commitbe4a142884f040a7fd54fdbe40b1302d5fc2567a (patch)
tree8bf9310873be2240f46a582198fc953197dc4459 /libstdc++-v3/Makefile.am
parentdb9317ce3f0d37b601120509e633e1a8caaec35c (diff)
downloadgcc-be4a142884f040a7fd54fdbe40b1302d5fc2567a.tar.gz
2009-01-15 Benjamin Kosnik <bkoz@redhat.com>
PR libstdc++/32666 * config/abi/post/hppa-linux-gnu/baseline_symbols.txt: Update. 2009-01-15 Benjamin Kosnik <bkoz@redhat.com> PR libstdc++/32666 * Makefile.am (hosted_source): Remove libmath directory. * Makefile.in: Regenerate. * linkage.m4 (GLIBCXX_CHECK_COMPLEX_MATH_SUPPORT): Remove. (AC_REPLACE_MATHFUNCS): Remove. (GLIBCXX_CHECK_MATH_SUPPORT): Remove copysign, copysignl checks as done in GLIBCXX_CHECK_C99_TR1. * acinclude.m4: Remove libmath, need_math. * crossconfig.m4: Remove use of HAVE_COPYSIGN, HAVE_COPYSIGNL, HAVE_COPYSIGNF, GLIBCXX_CHECK_COMPLEX_MATH_SUPPORT, need_libmath. * configure.ac: Same. * configure: Regenerate. * fragment.am: Fix comment. * config.h.in: Regenerate. * src/Makefile.in: Regenerate. * src/Makefile.am: Remove libmath references. * doc/Makefile.in: Regenerate. * po/Makefile.in: Regenerate. * include/Makefile.in: Regenerate. * libsupc++/Makefile.in: Regenerate. * testsuite/Makefile.in: Regenerate. * src/compatibility.cc: Also export long double versions of "C" math library if hppa-linux. * config/abi/pre/gnu.ver: Remove unused __signbit exports. * doc/xml/manual/appendix_contributing.xml: Remove libmath reference. * libmath: Remove. * libmath/signbit.c: Same. * libmath/stubs.c: Same. * libmath/Makefile.in: Same. * libmath/copysignf.c: Same. * libmath/mathconf.h: Same. * libmath/signbitf.c: Same. * libmath/Makefile.am: Same. * libmath/signbitl.c: Same. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@143406 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index 7ab27f0344d..4beb34bc815 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -1,6 +1,6 @@
## Makefile for the toplevel directory of the GNU C++ Standard library.
##
-## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2008
+## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2008, 2009
## Free Software Foundation, Inc.
##
## This file is part of the libstdc++ version 3 distribution.
@@ -25,7 +25,7 @@
include $(top_srcdir)/fragment.am
if GLIBCXX_HOSTED
- hosted_source = libmath doc src po testsuite
+ hosted_source = doc src po testsuite
endif
## Keep this list sync'd with acinclude.m4:GLIBCXX_CONFIGURE.
SUBDIRS = include libsupc++ $(hosted_source)