summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Kosnik <bkoz@redhat.com>2010-12-31 22:20:22 +0000
committerBenjamin Kosnik <bkoz@gcc.gnu.org>2010-12-31 22:20:22 +0000
commitb25e6b793c982405269ef59523fb740b5bd19a23 (patch)
tree8a19022eb57a77ffe9ddc0e3cab0594dbb826bc9 /libstdc++-v3/Makefile.am
parent132a545967fb8a624238fe7308b371032a0536f6 (diff)
downloadgcc-b25e6b793c982405269ef59523fb740b5bd19a23.tar.gz
run_doxygen: Allow doxygen 1.7.1 again.
2010-12-31 Benjamin Kosnik <bkoz@redhat.com> * scripts/run_doxygen: Allow doxygen 1.7.1 again. * doc/xml/manual/build_hacking.xml: Update. * doc/xml/images/confdeps.dot: Same. * doc/xml/images/confdeps.png: Same. * configure.ac: Define BUILD_INFO, BUILD_XML, BUILD_HTML, BUILD_MAN, BUILD_PDF, BUILD_EPUB conditionally. * Makefile.am (xml, html, pdf, man, info, pd, dvi, epub): Define, and install rules. * doc/Makefile.am: Same. Add stamp rules. (doc-epub-docbook): Add. (stamp-xml-single-docbook): Make set too. * configure: Regenerate. * Makefile.in: Same. * doc/Makefile.in: Same. * include/Makefile.in: Same. * libsupc++/Makefile.in: Same. * po/Makefile.in: Same. * python/Makefile.in: Same. * src/Makefile.in: Same. * testsuite/Makefile.in: Same. * aclocal.m4: Same. 2010-12-31 Benjamin Kosnik <bkoz@redhat.com> * doc/doxygen/user.cfg.in: Disable PDF_HYPERLINKS. From-SVN: r168382
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am90
1 files changed, 88 insertions, 2 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index c7a22aaa33c..f1b5b078790 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -1,6 +1,6 @@
## Makefile for the toplevel directory of the GNU C++ Standard library.
##
-## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2008, 2009
+## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2008, 2009, 2010
## Free Software Foundation, Inc.
##
## This file is part of the libstdc++ version 3 distribution.
@@ -26,19 +26,105 @@ include $(top_srcdir)/fragment.am
if GLIBCXX_HOSTED
hosted_source = doc src po testsuite
endif
+
## Keep this list sync'd with acinclude.m4:GLIBCXX_CONFIGURE.
## Note that python must come after src.
SUBDIRS = include libsupc++ $(hosted_source) python
ACLOCAL_AMFLAGS = -I . -I .. -I ../config
-# Handy forwarding targets.
+# Testsuite/check forwarding targets.
check-%:
cd testsuite && $(MAKE) $@
+# Documentation forwarding targets.
doc-%:
cd doc && $(MAKE) $@
+# Documentation conditionals for output.
+if BUILD_XML
+STAMP_XML = doc-xml
+STAMP_INSTALL_XML = doc-install-xml
+else
+STAMP_XML =
+STAMP_INSTALL_XML =
+endif
+
+if BUILD_HTML
+STAMP_HTML = doc-html
+STAMP_INSTALL_HTML = doc-install-html
+else
+STAMP_HTML =
+STAMP_INSTALL_HTML =
+endif
+
+if BUILD_MAN
+STAMP_MAN = doc-man
+STAMP_INSTALL_MAN = doc-install-man
+else
+STAMP_MAN =
+STAMP_INSTALL_MAN =
+endif
+
+if BUILD_PDF
+STAMP_PDF = doc-pdf
+STAMP_INSTALL_PDF = doc-install-pdf
+else
+STAMP_PDF =
+STAMP_INSTALL_PDF =
+endif
+
+if BUILD_EPUB
+STAMP_EPUB = doc-epub
+STAMP_INSTALL_EPUB = doc-install-epub
+else
+STAMP_EPUB = doc-epub
+STAMP_INSTALL_EPUB = doc-install-epub
+endif
+
+# Documentation primary rules.
+#
+# xml:
+# html:
+# pdf:
+# man:
+# info:
+# ps:
+# dvi:
+# epub:
+# install-xml:
+# install-html:
+# install-pdf:
+# install-man:
+# install-info:
+# install-ps:
+# install-dvi:
+# install-epub:
+
+xml: $(STAMP_XML)
+install-xml: $(STAMP_INSTALL_XML)
+
+html: $(STAMP_HTML)
+install-html: $(STAMP_INSTALL_HTML)
+
+man: $(STAMP_MAN)
+install-man: $(STAMP_INSTALL_MAN)
+
+pdf: $(STAMP_PDF)
+install-pdf: $(STAMP_INSTALL_PDF)
+
+epub: $(STAMP_EPUB)
+install-epub: $(STAMP_INSTALL_EPUB)
+
+info:
+install-info:
+
+ps:
+install-ps:
+
+dvi:
+install-dvi:
+
# Multilib support.
MAKEOVERRIDES=