summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2003-08-17 20:23:12 +0000
committerpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2003-08-17 20:23:12 +0000
commit2eb169cd8166ba8342c6783d1d21c0848c7fd156 (patch)
treebc40445978d8406152440975e0c56f5763886180 /libstdc++-v3/Makefile.am
parent049cadd673cd20c803614319a0075e2925acd3ce (diff)
downloadgcc-2eb169cd8166ba8342c6783d1d21c0848c7fd156.tar.gz
2003-08-17 Phil Edwards <pme@gcc.gnu.org>
* acinclude.m4 (GLIBCXX_EXPORT_INCLUDES): Remove LIBMATH_INCLUDES and LIBSUPCXX_INCLUDES. Re-purpose TOPLEVEL_INCLUDES to refer to things from the top level. * configure.ac (GLIBCXX_IS_NATIVE): Determine earlier and re-order. Comment out the conditionals for CANADIAN and GLIBCXX_BUILD_LIBMATH (currently unused). Strip the fake-VPATH shell fragment from automake-generated rules, if present. * linkage.m4: Add comment. * fragment.am: New file, containing factored-out common settings. (AM_CPPFLAGS): Absorb the deprecated INCLUDES variable contents. * Makefile.am: Include fragment.am. Remove common variables. * include/Makefile.am: Likewise. * libmath/Makefile.am: Likewise. * libsupc++/Makefile.am: Likewise. * po/Makefile.am: Likewise. Print rules during check. * src/Makefile.am: Likewise. * testsuite/Makefile.am: Likewise. * aclocal.m4, configure, Makefile.in, include/Makefile.in, libmath/Makefile.in, libsupc++/Makefile.in, po/Makefile.in, src/Makefile.in, testsuite/Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@70522 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index 5830ec3d1cf..51cfac825c4 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -22,14 +22,10 @@
## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
## USA.
-MAINT_CHARSET = latin1
+include $(top_srcdir)/fragment.am
SUBDIRS = include libmath libsupc++ src po testsuite
-mkinstalldirs = $(SHELL) $(toplevel_srcdir)/mkinstalldirs
-
-PWD_COMMAND = $${PWDCMD-pwd}
-
# These rules are messy, but are hella worth it.
doxygen:
-(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \