summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2002-08-22 20:06:01 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2002-08-22 20:06:01 +0000
commit0617d50e65b21e97243390d4eaf68b1a88945cce (patch)
tree34fa1db058806922836448134a99ca23f8a44849 /libstdc++-v3/Makefile.am
parent4cb3434511c0a3292d6e06e6bc7faed4a34bcf82 (diff)
downloadgcc-0617d50e65b21e97243390d4eaf68b1a88945cce.tar.gz
2002-08-22 Benjamin Kosnik <bkoz@redhat.com>
Phil Edwards <pme@gcc.gnu.org> Ulrich Drepper <drepper@redhat.com> * Makefile.am (check-abi): New rule. * Makefile.in: Regenerate. * acinclude.m4 (GLIBCPP_CONFIGURE_TESTSUITE): Export baseline_file. * aclocal.m4: Regenerate. * configure: Regenerate. * testsuite/Makefile.am (noinst_PROGRAMS): Add abi_check. (abi_check_SOURCES): Add. * testsuite/Makefile.in: Regenerate. * testsuite/abi_check.cc: New file. * config/abi: Add. * config/abi/i686-pc-linux-gnu: Add. * config/abi/i686-pc-linux-gnu/baseline_symbols.txt: New file. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@56515 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index d7b88141dc0..99d9c731e1c 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -46,6 +46,11 @@ check-script-install: $(top_builddir)/mkcheck
cd testsuite; \
@glibcpp_builddir@/mkcheck 1)
+baseline_file = @baseline_file@
+check-abi: $(top_builddir)/testsuite/abi_check
+ -(cd testsuite; \
+ abi_check @baseline_file@)
+
# These rules are messy, but are hella worth it.
doxygen:
-(srcdir=`cd ${top_srcdir}; ${PWD}`; \