summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2001-05-14 01:15:36 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2001-05-14 01:15:36 +0000
commit5ffc3b87b9ef20f3e2f7e1a2abe0bb4f0d0de6e3 (patch)
tree1ed29dbb4d80462a7bbcb51d061f4b720091f586 /libstdc++-v3/Makefile.am
parent14c42a3e5a42b1040e6a0ece3c9ae15bf64347d6 (diff)
downloadgcc-5ffc3b87b9ef20f3e2f7e1a2abe0bb4f0d0de6e3.tar.gz
2001-05-13 Benjamin Kosnik <bkoz@redhat.com>
Switch over to new harness. * testsuite_flags.in: Tweaks via Gaby. * testsuite/Makefile.am: Change tool to libstdc++-v3. (EXPECT): Quote directly. (RUNTEST): Same. * configure.in: Output testsuite_flags. * acinclude.m4: Substitute src, bld, and prefix dirs. Remove glibcpp_expect, glibcpp_runtestflags. * Makefile.am (RUNTESTFLAGS): Pass this down to subdirs. * mkcheck.in: Port to new interface. * aclocal.m4: Regerate. * configure: Regnerate. * Makefile.in: Regnerate. * */Makefile.in: Regenerate. * tests_flags.in: Remove. * testsuite/lib/libstdc++.exp: Remove. * testsuite/libstdc++.tests/tests.exp: Remove. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@42055 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index 0f32f384aa9..3ca98d5b18b 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -28,23 +28,24 @@ SUBDIRS = libio libmath libsupc++ src testsuite
mkinstalldirs = $(SHELL) $(toplevel_srcdir)/mkinstalldirs
-# Use $${builddir} instead of $(top_builddir) for arguments to "mkcheck"
-# because then the paths will be full pathnames, not relative
-# pathnames. (-Wl,--rpath seems to like this better.)
+# These two special 'check-script' rules use the bash script 'mkcheck'
+# to do testing. This script is not as portable as the dejagnu test
+# harness, and is thus off by default. It does produce interesting
+# output however, including various performance analysis items like
+# compile time, execution time, and binary size.
check-script: $(top_builddir)/mkcheck
-(chmod + $(top_builddir)/mkcheck; \
- srcdir=`cd $(top_srcdir); pwd`; builddir=`pwd`; \
test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
- cd testsuite; $${builddir}/mkcheck 0 $${builddir} $${srcdir})
+ cd testsuite; \
+ @glibcpp_builddir@/mkcheck 0)
check-script-install: $(top_builddir)/mkcheck
-(chmod + $(top_builddir)/mkcheck; \
- srcdir=`cd $(top_srcdir); pwd`; builddir=`pwd`; \
test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
cd testsuite; \
- $${builddir}/mkcheck 1 $${builddir} $${srcdir} $(prefix))
+ @glibcpp_builddir@/mkcheck 1)
-# These two rules seem messy.
+# These two rules might seem messy, but are hella worth it.
doxygen:
-(srcdir=`cd ${top_srcdir}; pwd`; \
outdir=`pwd`; \
@@ -121,6 +122,7 @@ AM_MAKEFLAGS = \
"PICFLAG=$(PICFLAG)" \
"PICFLAG_FOR_TARGET=$(PICFLAG_FOR_TARGET)" \
"SHELL=$(SHELL)" \
+ "RUNTESTFLAGS=$(RUNTESTFLAGS)" \
"exec_prefix=$(exec_prefix)" \
"infodir=$(infodir)" \
"libdir=$(libdir)" \