summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2003-08-27 19:06:56 +0000
committerpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2003-08-27 19:06:56 +0000
commit11764568741aa1f18cf60ee6099b73a922e736c4 (patch)
treed38037daf02cdd90f73e292b4bafe5c70a210f8a /libstdc++-v3/Makefile.am
parentc2c1332a4a09d25fd02fcef5c34080763437080b (diff)
downloadgcc-11764568741aa1f18cf60ee6099b73a922e736c4.tar.gz
2003-08-27 Phil Edwards <pme@gcc.gnu.org>
* acinclude.m4 (GLIBCXX_CONDITIONAL): New macro. Wrap AM_CONDITIONAL. Replace all calls to AM_CONDITIONAL with this one. (GLIBCXX_ENABLE_HOSTED): New macro, sets new variable is_hosted, used elsewhere in this file. (GLIBCXX_EVALUATE_CONDITIONALS): New macro... * configure.ac: ...called here to expand all conditionals. * Makefile.am: Conditionalize SUBDIRS on GLIBCXX_HOSTED. * include/Makefile.am: Remove redundant gxx_include_dir assignment. (install-freestanding-headers): New target, a subset of install-headers. Conditionalize install-data-local on GLIBCXX_HOSTED. * aclocal.m4, configure, Makefile.in, include/Makefile.in, libmath/Makefile.in, libsupc++/Makefile.in, po/Makefile.in, src/Makefile.in, testsuite/Makefile.in: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@70854 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index 59ab45cecbd..2c3db0e9480 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -24,8 +24,12 @@
include $(top_srcdir)/fragment.am
+if GLIBCXX_HOSTED
+ # Possibly libmath as well...
+ hosted_source = src po
+endif
## Keep this list sync'd with acinclude.m4:GLIBCXX_CONFIGURE.
-SUBDIRS = include libmath libsupc++ src po testsuite
+SUBDIRS = include libmath libsupc++ $(hosted_source) testsuite
# These rules are messy, but are hella worth it.
doxygen: