summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2000-10-12 11:45:23 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2000-10-12 11:45:23 +0000
commit71dbcf67f6fc13a683a03cce6d2b24bcd6613621 (patch)
tree7f6039bd616b820b96f24b611150b025625af2b3 /libstdc++-v3/Makefile.am
parent54cb6349d9bd0352a2f3fa36bc17fd76f0fbcdc2 (diff)
downloadgcc-71dbcf67f6fc13a683a03cce6d2b24bcd6613621.tar.gz
2000-10-11 Benjamin Kosnik <bkoz@purist.soma.redhat.com>
* libsupc++/Makefile.am: Use it. * libio/Makefile.am: Use it. * libmath/Makefile.am: Use it. * src/Makefile.am: Use it. * Makefile.am (AM_MAKEFLAGS): Remove includes. * acinclude.m4 (GLIBCPP_EXPORT_INCLUES): Move include macros here. (GLIBCPP_EXPORT_FLAGS): Move CXX flag setting here. * configure.in: Use it. * mkcheck.in (SRC_DIR): Use C_INCLUDE_DIR. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@36847 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am60
1 files changed, 1 insertions, 59 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index 530ccc36fd1..ced6ed6bc9a 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -32,54 +32,6 @@ gxx_include_dir=$(includedir)/g++
SUBDIRS = libio libmath libsupc++ src
-# Compile flags that should be constant throughout the build, both for
-# SUBDIRS and for libstdc++-v3 in general.
-# Optimization flags that are probably a good idea for thrill-seekers. Just
-# uncomment the lines below and make, everything else is ready to go...
-# OPTIMIZE_CXXFLAGS = -O3 -fstrict-aliasing -fvtable-gc
-OPTIMIZE_CXXFLAGS =
-
-# Warning flags to use.
-WARN_CXXFLAGS = \
- -Wall -Wno-format -W -Wwrite-strings -Winline \
- $(WERROR) @WFMT_FLAGS@
-
-# These bits are all figured out from configure. Look in acinclude.m4
-# or configure.in to see how they are set.
-# NB: DEBUGFLAGS have to be at the end so that -O2 can be overridden.
-CONFIG_CXXFLAGS = \
- @EXTRA_CXX_FLAGS@ \
- @SECTION_FLAGS@ @CSHADOWFLAGS@ @DEBUG_FLAGS@
-
-
-# Root level of the include sources.
-GLIBCPP_INCLUDE_DIR = $(top_srcdir)/include
-
-# Can either use include/c or include/c_std to grab "C" headers. This
-# variable is set to the include directory currently in use.
-C_INCLUDE_DIR = $(GLIBCPP_INCLUDE_DIR)/@c_include_dir@
-
-
-# Passed down for cross compilers, canadian crosses.
-TOPLEVEL_INCLUDES = -I$(includedir)
-
-LIBMATH_INCLUDES = -I$(top_srcdir)/libmath
-
-if GLIBCPP_NEED_LIBIO
-LIBIO_INCLUDES = \
- -I$(top_builddir)/libio -I$(top_srcdir)/libio
-else
-LIBIO_INCLUDES = -I$(top_srcdir)/libio
-endif
-
-LIBSUPCXX_INCLUDES = -I$(top_srcdir)/libsupc++
-
-# XXX May need to add this in later to enabled shadow header includes
-# -I$(top_builddir)/cshadow
-CSHADOW_INCLUDES = \
- -I$(GLIBCPP_INCLUDE_DIR)/std -I$(C_INCLUDE_DIR)
-
-
# Use $(blddir) instead of $(top_builddir) for arguments to "mkcheck"
# because then the paths will be full pathnames, not relative
# pathnames. (-Wl,--rpath seems to like this better.)
@@ -174,14 +126,4 @@ AM_MAKEFLAGS = \
"NM_FOR_BUILD=$(NM_FOR_BUILD)" \
"NM_FOR_TARGET=$(NM_FOR_TARGET)" \
"DESTDIR=$(DESTDIR)" \
- "WERROR=$(WERROR)" \
- "OPTIMIZE_CXXFLAGS=$(OPTIMIZE_CXXFLAGS)" \
- "WARN_CXXFLAGS=$(WARN_CXXFLAGS)" \
- "CONFIG_CXXFLAGS=$(CONFIG_CXXFLAGS)" \
- "GLIBCPP_INCLUDE_DIR=$(GLIBCPP_INCLUDE_DIR)" \
- "C_INCLUDE_DIR=$(C_INCLUDE_DIR)" \
- "TOPLEVEL_INCLUDES=$(TOPLEVEL_INCLUDES)" \
- "LIBMATH_INCLUDES=$(LIBMATH_INCLUDES)" \
- "LIBIO_INCLUDES=$(LIBIO_INCLUDES)" \
- "CSHADOW_INCLUDES=$(CSHADOW_INCLUDES)" \
- "LIBSUPCXX_INCLUDES=$(LIBSUPCXX_INCLUDES)"
+ "WERROR=$(WERROR)" \ No newline at end of file