summaryrefslogtreecommitdiff
path: root/libstdc++-v3/configure.ac
diff options
context:
space:
mode:
authorpaolo <paolo@138bc75d-0d04-0410-961f-82ee72b054a4>2009-01-15 14:01:04 +0000
committerpaolo <paolo@138bc75d-0d04-0410-961f-82ee72b054a4>2009-01-15 14:01:04 +0000
commit99e43922811ec0cde4827bb388ff341034a1685e (patch)
treea3d0a02869ac2d4272d8edb67dd33bc6a37b3633 /libstdc++-v3/configure.ac
parent8408ca006c318141a4bde09a937d8ce7180d8bad (diff)
downloadgcc-99e43922811ec0cde4827bb388ff341034a1685e.tar.gz
2009-01-15 Chris Fairles <cfairles@gcc.gnu.org>
Paolo Carlini <paolo.carlini@oracle.com> * acinclude.m4 ([GLIBCXX_ENABLE_CLOCK_GETTIME], [GLIBCXX_CHECK_NANOSLEEP]): Remove. ([GLIBCXX_ENABLE_LIBSTDCXX_TIME]): Add. * configure.ac: Adjust. * doc/xml/manual/configure.xml: Update. * testsuite/lib/libstdc++.exp (check_v3_target_sched_yield): Add. * testsuite/lib/dg-options.exp (dg-require-sched-yield): Add. * testsuite/30_threads/thread/this_thread/2.cc: Use the latter. * configure: Regenerate. * config.h.in: Likewise. * src/thread.cc (thread::thread(), thread::~thread, thread::get_id, thread::joinable, thread::swap, this_thread::get_id, this_thread::yield): Define inline... * include/std/thread: ... here. * config/abi/pre/gnu.ver: Adjust. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@143397 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/configure.ac')
-rw-r--r--libstdc++-v3/configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/libstdc++-v3/configure.ac b/libstdc++-v3/configure.ac
index 36701f2ab96..ae97d896876 100644
--- a/libstdc++-v3/configure.ac
+++ b/libstdc++-v3/configure.ac
@@ -145,16 +145,13 @@ GLIBCXX_CHECK_STDIO_MACROS
# For gettimeofday support.
GLIBCXX_CHECK_GETTIMEOFDAY
-# For clock_gettime support.
+# For clock_gettime, nanosleep and sched_yield support.
# NB: The default is [no], because otherwise it requires linking.
-GLIBCXX_ENABLE_CLOCK_GETTIME([no])
+GLIBCXX_ENABLE_LIBSTDCXX_TIME([no])
# For gthread support
GLIBCXX_CHECK_GTHREADS
-# For nanosleep support
-GLIBCXX_CHECK_NANOSLEEP
-
AC_LC_MESSAGES
# Check for available headers.