summaryrefslogtreecommitdiff
path: root/libstdc++-v3/configure.ac
diff options
context:
space:
mode:
authorredi <redi@138bc75d-0d04-0410-961f-82ee72b054a4>2011-05-28 17:27:01 +0000
committerredi <redi@138bc75d-0d04-0410-961f-82ee72b054a4>2011-05-28 17:27:01 +0000
commitf4d90d643e07a9b40194b41233f5bdf2a7ef1b17 (patch)
tree0ed25a637a039c2d5d231df811fefc8e6ec64536 /libstdc++-v3/configure.ac
parent792d374c1a7bc54243c2c22eba5199cf82b05b7d (diff)
downloadgcc-f4d90d643e07a9b40194b41233f5bdf2a7ef1b17.tar.gz
2011-05-28 Jonathan Wakely <jwakely.gcc@gmail.com>
* acinclude.m4: Define GLIBCXX_CHECK_GET_NPROCS and GLIBCXX_CHECK_SC_NPROCESSORS_ONLN. * configure.ac: Use them. Increase minor version. * configure: Regenerate. * config.h.in: Regenerate. * include/std/thread (thread::hardware_concurrency): Remove inline definition. * src/thread.cc (thread::hardware_concurrency): Define. * config/abi/pre/gnu.ver: Export new symbol @3.4.17 * testsuite/util/testsuite_abi.cc: Add new version. * testsuite/lib/libstdc++.exp (check_v3_target_nprocs): Add. * testsuite/lib/dg-options.exp (dg-require-nprocs): Add. * testsuite/30_threads/thread/members/hardware_concurrency.cc: Use dg-require-nprocs and verify hardware_concurrency returns non-zero. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@174383 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/configure.ac')
-rw-r--r--libstdc++-v3/configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/libstdc++-v3/configure.ac b/libstdc++-v3/configure.ac
index 35c54fd4e9a..416c0d72d68 100644
--- a/libstdc++-v3/configure.ac
+++ b/libstdc++-v3/configure.ac
@@ -12,7 +12,7 @@ AC_CONFIG_HEADER(config.h)
### am handles this now? ORIGINAL_LD_FOR_MULTILIBS=$LD
# For libtool versioning info, format is CURRENT:REVISION:AGE
-libtool_VERSION=6:16:0
+libtool_VERSION=6:17:0
AC_SUBST(libtool_VERSION)
# Find the rest of the source tree framework.
@@ -170,6 +170,12 @@ GLIBCXX_CHECK_GTHREADS
AC_LC_MESSAGES
+# For hardware_concurrency
+AC_CHECK_HEADERS(sys/sysinfo.h)
+GLIBCXX_CHECK_GET_NPROCS
+AC_CHECK_HEADERS(unistd.h)
+GLIBCXX_CHECK_SC_NPROCESSORS_ONLN
+
# Check for available headers.
AC_CHECK_HEADERS([endian.h execinfo.h float.h fp.h ieeefp.h inttypes.h \
locale.h machine/endian.h machine/param.h nan.h stdint.h stdlib.h string.h \