summaryrefslogtreecommitdiff
path: root/libstdc++-v3/configure.ac
diff options
context:
space:
mode:
authordannysmith <dannysmith@138bc75d-0d04-0410-961f-82ee72b054a4>2007-09-07 04:18:40 +0000
committerdannysmith <dannysmith@138bc75d-0d04-0410-961f-82ee72b054a4>2007-09-07 04:18:40 +0000
commit7c2eae61f35212eefb71613c0683d19404ac2977 (patch)
tree098c7c8d3758271a7b929965b5460afab61399cb /libstdc++-v3/configure.ac
parente4ef06d071a62aedafa371163cf3b52d6b2b9010 (diff)
downloadgcc-7c2eae61f35212eefb71613c0683d19404ac2977.tar.gz
PR libstdc++/33203
* configure.host (error_constants_dir): New variable, defaulting to os/generic. ( mingw32*): Overide default. * configure.ac (ERROR_CONSTANTS_SRCDIR): New. * configure: Regenerate. * include/Makefile.am (host_headers): Add $(ERROR_CONSTANTS_SRCDIR)/error_constants.h . * include/Makefile.in: Regenerate. * include/std/system_error (enum posix_errno): Remove. Include <bits/error_constants.h> instead. * config/os/mingw32/error_constants.h: New. * config/os/generic/error_constants.h: New. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@128228 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/configure.ac')
-rw-r--r--libstdc++-v3/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/libstdc++-v3/configure.ac b/libstdc++-v3/configure.ac
index 4ad8d0ebfad..a89e21df8a8 100644
--- a/libstdc++-v3/configure.ac
+++ b/libstdc++-v3/configure.ac
@@ -329,12 +329,14 @@ ATOMICITY_SRCDIR=config/${atomicity_dir}
ATOMIC_WORD_SRCDIR=config/${atomic_word_dir}
CPU_DEFINES_SRCDIR=config/${cpu_defines_dir}
OS_INC_SRCDIR=config/${os_include_dir}
+ERROR_CONSTANTS_SRCDIR=config/${error_constants_dir}
ABI_TWEAKS_SRCDIR=config/${abi_tweaks_dir}
AC_SUBST(ATOMICITY_SRCDIR)
AC_SUBST(ATOMIC_WORD_SRCDIR)
AC_SUBST(CPU_DEFINES_SRCDIR)
AC_SUBST(ABI_TWEAKS_SRCDIR)
AC_SUBST(OS_INC_SRCDIR)
+AC_SUBST(ERROR_CONSTANTS_SRCDIR)
# Determine cross-compile flags and AM_CONDITIONALs.