summaryrefslogtreecommitdiff
path: root/libstdc++-v3/configure.in
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2000-10-15 08:45:33 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2000-10-15 08:45:33 +0000
commit8bc04851c4f32955915c48ec87b806f644727a1a (patch)
treefe7efb1135f7c1d7c4510ab96884579a75f157c9 /libstdc++-v3/configure.in
parenta612d5a42f70b65b3c48c4f3100ff1f1da3db65b (diff)
downloadgcc-8bc04851c4f32955915c48ec87b806f644727a1a.tar.gz
2000-10-13 Benjamin Kosnik <bkoz@purist.soma.redhat.com>
Mark Harig <markh@landmark.com> * src/Makefile.am (toolexeclibdir): Add support fo VERSION_SPECIFIC_LIBS and --with-gxx-include-dir. * src/Makefile.in: Regenerate. * libsupc++/Makefile.am: Same. (glibcppinstalldir): Adjust. * libsupc++/Makefile.in: Regenerate. * Makefile.am: Remove gxx_include_dir. Remove INCLUDE. * Makefile.in: Regenerate. * docs/configopts.html: Add descriptions of flags. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@36872 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/configure.in')
-rw-r--r--libstdc++-v3/configure.in123
1 files changed, 89 insertions, 34 deletions
diff --git a/libstdc++-v3/configure.in b/libstdc++-v3/configure.in
index e0c321d6198..bd8978bfb05 100644
--- a/libstdc++-v3/configure.in
+++ b/libstdc++-v3/configure.in
@@ -66,46 +66,46 @@ if test -n "$with_cross_host"; then
# currently calling it.
AC_DEFINE(HAVE_FLOAT_H)
- AC_DEFINE(HAVE__FINITE)
- AC_DEFINE(HAVE__ISNAN)
- AC_DEFINE(HAVE__COPYSIGN)
- AC_DEFINE(HAVE__FPCLASS)
- AC_DEFINE(HAVE_MODF)
-
- ctype_include_dir="config/os/wince"
- AC_LINK_FILES($ctype_include_dir/bits/ctype_base.h, bits/ctype_base.h)
- AC_LINK_FILES($ctype_include_dir/bits/ctype_inline.h, \
+ AC_DEFINE(HAVE__FINITE)
+ AC_DEFINE(HAVE__ISNAN)
+ AC_DEFINE(HAVE__COPYSIGN)
+ AC_DEFINE(HAVE__FPCLASS)
+ AC_DEFINE(HAVE_MODF)
+
+ ctype_include_dir="config/os/wince"
+ AC_LINK_FILES($ctype_include_dir/bits/ctype_base.h, bits/ctype_base.h)
+ AC_LINK_FILES($ctype_include_dir/bits/ctype_inline.h, \
bits/ctype_inline.h)
- AC_LINK_FILES($ctype_include_dir/bits/ctype_noninline.h, \
+ AC_LINK_FILES($ctype_include_dir/bits/ctype_noninline.h, \
bits/ctype_noninline.h)
- AC_DEFINE(_GLIBCPP_NEED_MBSTATE_T)
+ AC_DEFINE(_GLIBCPP_NEED_MBSTATE_T)
- AC_DEFINE(_GLIBCPP_BUGGY_FLOAT_COMPLEX)
- AC_DEFINE(_GLIBCPP_BUGGY_COMPLEX)
+ AC_DEFINE(_GLIBCPP_BUGGY_FLOAT_COMPLEX)
+ AC_DEFINE(_GLIBCPP_BUGGY_COMPLEX)
;;
*)
# We assume newlib. This lets us hard-code the functions we know
# we'll have.
- AC_DEFINE(HAVE_FINITE)
- AC_DEFINE(HAVE_ISNAN)
- AC_DEFINE(HAVE_ISNANF)
- AC_DEFINE(HAVE_ISINF)
- AC_DEFINE(HAVE_ISINFF)
-
- ctype_include_dir="config/os/newlib"
- AC_LINK_FILES($ctype_include_dir/bits/ctype_base.h, bits/ctype_base.h)
- AC_LINK_FILES($ctype_include_dir/bits/ctype_inline.h, \
+ AC_DEFINE(HAVE_FINITE)
+ AC_DEFINE(HAVE_ISNAN)
+ AC_DEFINE(HAVE_ISNANF)
+ AC_DEFINE(HAVE_ISINF)
+ AC_DEFINE(HAVE_ISINFF)
+
+ ctype_include_dir="config/os/newlib"
+ AC_LINK_FILES($ctype_include_dir/bits/ctype_base.h, bits/ctype_base.h)
+ AC_LINK_FILES($ctype_include_dir/bits/ctype_inline.h, \
bits/ctype_inline.h)
- AC_LINK_FILES($ctype_include_dir/bits/ctype_noninline.h, \
+ AC_LINK_FILES($ctype_include_dir/bits/ctype_noninline.h, \
bits/ctype_noninline.h)
- AC_DEFINE(_GLIBCPP_NEED_MBSTATE_T)
+ AC_DEFINE(_GLIBCPP_NEED_MBSTATE_T)
- AC_DEFINE(_GLIBCPP_BUGGY_FLOAT_COMPLEX)
- AC_DEFINE(_GLIBCPP_BUGGY_COMPLEX)
- # need to ceck for faster f versions of math functions, ie sinf?
+ AC_DEFINE(_GLIBCPP_BUGGY_FLOAT_COMPLEX)
+ AC_DEFINE(_GLIBCPP_BUGGY_COMPLEX)
+ # need to ceck for faster f versions of math functions, ie sinf?
;;
esac
else
@@ -152,6 +152,62 @@ fi
# Generate the various Makefiles, include files, and scripts.
+# This helps subvert libstdcxx_interface, as calculated by devo/config.if
+# Needed so that g++ can find the correct include subdir automatically.
+INTERFACE=v3
+
+# Check for the interface version number for specifying where header
+# files are installed, if a version number is provided.
+AC_MSG_CHECKING([for interface version number])
+libstdcxx_interface=$INTERFACE
+AC_MSG_RESULT($libstdcxx_interface)
+AC_SUBST(libstdcxx_interface)
+
+# Process the option --with-gxx-include-dir=<path to include-files directory>
+AC_MSG_CHECKING([for --with-gxx-include-dir])
+AC_ARG_WITH(gxx-include-dir,
+[ --with-gxx-include-dir the installation directory for include files],
+[case "${withval}" in
+ yes)
+ AC_MSG_ERROR(Missing directory for --with-gxx-include-dir)
+ gxx_include_dir=no
+ ;;
+ no)
+ gxx_include_dir=no
+ ;;
+ *)
+ gxx_include_dir=${withval}
+ ;;
+esac], [gxx_include_dir=no])
+AC_MSG_RESULT($gxx_include_dir)
+AC_SUBST(gxx_include_dir)
+AM_CONDITIONAL(GXX_INCLUDE_DIR, test x${gxx_include_dir} != xno)
+
+# Process the option "--enable-version-specific-runtime-libs"
+AC_MSG_CHECKING([for --enable-version-specific-runtime-libs])
+AC_ARG_ENABLE(version-specific-runtime-libs,
+[ --enable-version-specific-runtime-libs Specify that runtime libraries should be installed in a compiler-specific directory ],
+[ version_specific_libs=yes
+# Need the gcc compiler version to know where to install libraries
+# and header files if --enable-version-specific-runtime-libs option
+# is selected.
+changequote(,)dnl
+gcc_tmp=`grep version_string ${srcdir}/../gcc/version.c | awk '{print $6}'`
+gcc_num=`echo ${gcc_tmp} | sed 's/\"//g'`
+#gcc_date=`grep version_string ${srcdir}/../gcc/version.c | awk '{print $7}'`
+#gcc_version=$gcc_num-$gcc_date
+gcc_version=$gcc_num
+changequote([,])dnl
+AC_SUBST(gcc_version)
+],version_specific_libs=no)
+AC_MSG_RESULT($version_specific_libs)
+if test x${version_specific_libs} = xyes; then
+ AM_CONDITIONAL(VERSION_SPECIFIC_LIBS, test x${version_specific_libs} = xyes)
+ AC_MSG_WARN(version specific directory is: $gcc_version)
+fi
+
+
+
# Export all the include and flag information to makefiles.
GLIBCPP_EXPORT_INCLUDES
GLIBCPP_EXPORT_FLAGS
@@ -184,18 +240,17 @@ blddir=`pwd`
AC_OUTPUT_COMMANDS([$srcdir/mkc++config $blddir $srcdir])
# Generate bits/std_limits.h and src/limitsMEMBERS.cc
-AC_OUTPUT_COMMANDS([$srcdir/mknumeric_limits $blddir $srcdir $xcompiling])
-
+if test ! -f stamp-limits; then
+ AC_OUTPUT_COMMANDS([$srcdir/mknumeric_limits $blddir $srcdir $xcompiling])
+ touch stamp-limits
+fi
# Sanity checking & User-visible messages.
# Checks down here, otherwise they get scrolled off before
# the user will notice.
-if test "$enable_namespaces" = "yes" && test "$enable_libgcc_rebuild" = "no"
-then
+if test "$enable_libgcc_rebuild" = "no"; then
AC_MSG_WARN([libgcc.a will not match mangled symbols unless it is rebuilt])
-fi
-if test "$enable_namespaces" = "no" && test "$enable_libgcc_rebuild" != "no"
-then
+else
# Other things besides namespaces can make this true as well, but none
# of them are done automatically... yet
AC_MSG_WARN([no point in rebuilding libgcc.a if namespaces aren't used])