summaryrefslogtreecommitdiff
path: root/libstdc++-v3/include/Makefile.am
diff options
context:
space:
mode:
authorrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2008-04-30 16:43:08 +0000
committerrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2008-04-30 16:43:08 +0000
commit2360a55cc763a4f343b9b855be8e5d52ccd48eda (patch)
treefa141aa061ded82ab65c7a23c51bd0f5313182b7 /libstdc++-v3/include/Makefile.am
parent19872d0b68288db5da85d3db3f89d9d70080644f (diff)
downloadgcc-2360a55cc763a4f343b9b855be8e5d52ccd48eda.tar.gz
libstdc++-v3/
* include/Makefile.am (install-headers): Cope with empty parallel_headers. * include/Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@134829 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/include/Makefile.am')
-rw-r--r--libstdc++-v3/include/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/libstdc++-v3/include/Makefile.am b/libstdc++-v3/include/Makefile.am
index 22ac39c436b..a867f009c3a 100644
--- a/libstdc++-v3/include/Makefile.am
+++ b/libstdc++-v3/include/Makefile.am
@@ -1196,8 +1196,10 @@ install-headers:
$(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${debug_builddir}
for file in ${debug_headers}; do \
$(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${debug_builddir}; done
- $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${parallel_builddir}
- for file in ${parallel_headers}; do \
+ parallel_headers_install='${parallel_headers}';\
+ test -z "$$parallel_headers_install" || \
+ $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/${parallel_builddir};\
+ for file in $$parallel_headers_install; do \
$(INSTALL_DATA) $${file} $(DESTDIR)${gxx_include_dir}/${parallel_builddir}; done
$(mkinstalldirs) $(DESTDIR)${host_installdir}
for file in ${host_headers} ${host_headers_extra} \