summaryrefslogtreecommitdiff
path: root/libstdc++-v3/include/Makefile.am
diff options
context:
space:
mode:
authorpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2003-08-27 00:38:28 +0000
committerpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2003-08-27 00:38:28 +0000
commit4591e20f03e57b651cf3dac127909f747b4a92c7 (patch)
treedd98bcfa8b7c51e66c2927eed518cb1f935b1dc0 /libstdc++-v3/include/Makefile.am
parent7acd3d7d5190a8d527753e0c5727c9faec36a842 (diff)
downloadgcc-4591e20f03e57b651cf3dac127909f747b4a92c7.tar.gz
2003-08-26 Phil Edwards <pme@gcc.gnu.org>
* Makefile.am: Add comment. * acinclude.m4 (GLIBCXX_CONFIGURE): Set new glibcxx_SUBDIRS and SUBDIRS variables. * configure.ac: Use them both here, instead of hardcoded lists. * fragment.am: Add STAMP varaible. * include/Makefile.am: Cosmetic whitespace cleanup. Use $(LN_S) instead of @LN_S@. (stamp-*): Move file creation rule outside of 'if' branches to ensure the stamp-* files are actually updated. Use $(STAMP). * src/Makefile.am: Remove now-nonexistant variable. * libsupc++/Makefile.am: Likewise. Snap the assignment chain for -prefer-pic. * po/Makefile.am: Include same fragment as all the others. * aclocal.m4, configure, Makefile.in, include/Makefile.in, libsupc++/Makefile.in, po/Makefile.in, src/Makefile.in: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@70836 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/include/Makefile.am')
-rw-r--r--libstdc++-v3/include/Makefile.am92
1 files changed, 46 insertions, 46 deletions
diff --git a/libstdc++-v3/include/Makefile.am b/libstdc++-v3/include/Makefile.am
index 17d202d26dd..a7660d5ea15 100644
--- a/libstdc++-v3/include/Makefile.am
+++ b/libstdc++-v3/include/Makefile.am
@@ -56,7 +56,7 @@ std_headers = \
${std_srcdir}/std_utility.h \
${std_srcdir}/std_valarray.h \
${std_srcdir}/std_vector.h
-# Renamed at build time.
+# Renamed at build time.
std_headers_rename = \
algorithm \
bitset \
@@ -221,7 +221,7 @@ ext_headers = \
${ext_srcdir}/ropeimpl.h \
${ext_srcdir}/slist \
${ext_srcdir}/hash_fun.h \
- ${ext_srcdir}/hashtable.h
+ ${ext_srcdir}/hashtable.h
# This is the common subset of files that all three "C" header models use.
@@ -245,7 +245,7 @@ c_base_headers = \
${c_base_srcdir}/std_cstring.h \
${c_base_srcdir}/std_ctime.h \
${c_base_srcdir}/std_cwchar.h \
- ${c_base_srcdir}/std_cwctype.h
+ ${c_base_srcdir}/std_cwctype.h
c_base_headers_rename = \
cassert \
cctype \
@@ -264,7 +264,7 @@ c_base_headers_rename = \
cstring \
ctime \
cwchar \
- cwctype
+ cwctype
# "C" compatibility headers.
c_compatibility_srcdir = ${glibcxx_srcdir}/include/c_compatibility
@@ -287,21 +287,21 @@ c_compatibility_headers = \
${c_compatibility_srcdir}/string.h \
${c_compatibility_srcdir}/time.h \
${c_compatibility_srcdir}/wchar.h \
- ${c_compatibility_srcdir}/wctype.h
+ ${c_compatibility_srcdir}/wctype.h
# Some of the different "C" header models need extra files.
# Some "C" header schemes require the "C" compatibility headers.
# For --enable-cheaders=c_std
if GLIBCXX_C_HEADERS_C_STD
-c_base_headers_extra = ${c_base_srcdir}/cmath.tcc
+c_base_headers_extra = ${c_base_srcdir}/cmath.tcc
else
-c_base_headers_extra =
+c_base_headers_extra =
endif
if GLIBCXX_C_HEADERS_COMPATIBILITY
c_compatibility_headers_extra = ${c_compatibility_headers}
else
-c_compatibility_headers_extra =
+c_compatibility_headers_extra =
endif
host_srcdir = ${glibcxx_srcdir}/@OS_INC_SRCDIR@
@@ -312,7 +312,7 @@ host_headers = \
${host_srcdir}/ctype_noninline.h \
${host_srcdir}/os_defines.h \
${glibcxx_srcdir}/@ATOMICITY_INC_SRCDIR@/atomicity.h \
- ${glibcxx_srcdir}/@FPOS_INC_SRCDIR@/fpos.h
+ ${glibcxx_srcdir}/@FPOS_INC_SRCDIR@/fpos.h
# Non-installed host_header files.
host_headers_noinst = \
@@ -342,15 +342,15 @@ if GLIBCXX_BUILD_PCH
pch_build = ${pch_input}
pch_install = install-pch
else
-pch_build =
-pch_install =
+pch_build =
+pch_install =
endif
# List of all timestamp files. By keeping only one copy of this list, both
# CLEANFILES and all-local are kept up-to-date.
allstamped = \
stamp-std stamp-bits stamp-c_base stamp-c_compatibility \
- stamp-backward stamp-ext stamp-host
+ stamp-backward stamp-ext stamp-host
# List of all files that are created by explicit building, editing, or
# catenation.
@@ -360,7 +360,7 @@ allcreated = \
${pch_build}
# Here are the rules for building the headers
-all-local: ${allstamped} ${allcreated}
+all-local: ${allstamped} ${allcreated}
# This rule is slightly different, in that we must change the name of the
# local file from std_foo.h to foo.
@@ -371,34 +371,34 @@ stamp-std: ${std_headers}
if [ ! -f stamp-std ]; then \
(cd ${std_builddir} && for h in $?; do \
official_name=`echo $$h | sed -e 's,.*/std_,,' -e 's,\.h$$,,'` ;\
- @LN_S@ $$h ./$${official_name} || true ;\
+ $(LN_S) $$h ./$${official_name} || true ;\
done) ;\
- echo `date` > stamp-std ;\
- fi
+ fi ;\
+ $(STAMP) stamp-std
stamp-bits: ${bits_headers}
@if [ ! -d "${bits_builddir}" ]; then \
mkdir -p ${bits_builddir} ;\
fi ;\
if [ ! -f stamp-bits ]; then \
- (cd ${bits_builddir} && @LN_S@ $? . || true) ;\
- echo `date` > stamp-bits ;\
- fi
+ (cd ${bits_builddir} && $(LN_S) $? . || true) ;\
+ fi ;\
+ $(STAMP) stamp-bits
-stamp-c_base: stamp-bits ${c_base_headers} ${c_base_headers_extra}
+stamp-c_base: stamp-bits ${c_base_headers} ${c_base_headers_extra}
@if [ ! -d "${c_base_builddir}" ]; then \
mkdir -p ${c_base_builddir} ;\
fi ;\
if [ ! -f stamp-c_base ]; then \
(cd ${c_base_builddir} && for h in ${c_base_headers}; do \
official_name=`echo $$h | sed -e 's,.*/std_,,' -e 's,\.h$$,,'` ;\
- @LN_S@ $$h ./$${official_name} || true ;\
+ $(LN_S) $$h ./$${official_name} || true ;\
done) ;\
if [ ! -z "${c_base_headers_extra}" ]; then \
- (cd ${bits_builddir} && @LN_S@ ${c_base_headers_extra} . || true) ;\
+ (cd ${bits_builddir} && $(LN_S) ${c_base_headers_extra} . || true) ;\
fi ;\
- echo `date` > stamp-c_base ;\
- fi
+ fi ;\
+ $(STAMP) stamp-c_base
stamp-c_compatibility: ${c_compatibility_headers_extra}
@if [ ! -d "${c_compatibility_builddir}" ]; then \
@@ -406,53 +406,53 @@ stamp-c_compatibility: ${c_compatibility_headers_extra}
fi ;\
if [ ! -f stamp-c_compatibility ]; then \
if [ ! -z "${c_compatibility_headers_extra}" ]; then \
- (cd ${c_compatibility_builddir} && @LN_S@ $? . || true) ;\
+ (cd ${c_compatibility_builddir} && $(LN_S) $? . || true) ;\
fi ;\
- echo `date` > stamp-c_compatibility ;\
- fi
+ fi ;\
+ $(STAMP) stamp-c_compatibility
stamp-backward: ${backward_headers}
@if [ ! -d "${backward_builddir}" ]; then \
mkdir -p ${backward_builddir} ;\
fi ;\
if [ ! -f stamp-backward ]; then \
- (cd ${backward_builddir} && @LN_S@ $? . || true) ;\
- echo `date` > stamp-backward ;\
- fi
+ (cd ${backward_builddir} && $(LN_S) $? . || true) ;\
+ fi ;\
+ $(STAMP) stamp-backward
stamp-ext: ${ext_headers}
@if [ ! -d "${ext_builddir}" ]; then \
mkdir -p ${ext_builddir} ;\
fi ;\
if [ ! -f stamp-ext ]; then \
- (cd ${ext_builddir} && @LN_S@ $? . || true) ;\
- echo `date` > stamp-ext ;\
- fi
+ (cd ${ext_builddir} && $(LN_S) $? . || true) ;\
+ fi ;\
+ $(STAMP) stamp-ext
stamp-${host_alias}:
@if [ ! -d ${host_builddir} ]; then \
mkdir -p ${host_builddir} ;\
- echo `date` > stamp-${host_alias} ;\
- fi
+ fi ;\
+ $(STAMP) stamp-${host_alias}
# Host includes static.
# XXX Missing dependency info for {host_headers_extra}
stamp-host: ${host_headers} ${host_headers_noinst} stamp-${host_alias}
@if [ ! -f stamp-host ]; then \
(cd ${host_builddir} ;\
- @LN_S@ ${host_headers} . || true ;\
- @LN_S@ ${glibcxx_srcdir}/@BASIC_FILE_H@ basic_file.h || true ;\
- @LN_S@ ${glibcxx_srcdir}/@CSTDIO_H@ c++io.h || true ;\
- @LN_S@ ${glibcxx_srcdir}/@CLOCALE_H@ c++locale.h || true ;\
- @LN_S@ ${glibcxx_srcdir}/@CLOCALE_INTERNAL_H@ . || true ;\
- @LN_S@ ${glibcxx_srcdir}/@CMESSAGES_H@ messages_members.h || true ;\
- @LN_S@ ${glibcxx_srcdir}/@CTIME_H@ time_members.h || true ;\
- @LN_S@ ${glibcxx_srcdir}/@CCODECVT_H@ codecvt_specializations.h || true);\
- echo `date` > stamp-host ; \
- fi
+ $(LN_S) ${host_headers} . || true ;\
+ $(LN_S) ${glibcxx_srcdir}/@BASIC_FILE_H@ basic_file.h || true ;\
+ $(LN_S) ${glibcxx_srcdir}/@CSTDIO_H@ c++io.h || true ;\
+ $(LN_S) ${glibcxx_srcdir}/@CLOCALE_H@ c++locale.h || true ;\
+ $(LN_S) ${glibcxx_srcdir}/@CLOCALE_INTERNAL_H@ . || true ;\
+ $(LN_S) ${glibcxx_srcdir}/@CMESSAGES_H@ messages_members.h || true ;\
+ $(LN_S) ${glibcxx_srcdir}/@CTIME_H@ time_members.h || true ;\
+ $(LN_S) ${glibcxx_srcdir}/@CCODECVT_H@ codecvt_specializations.h || true);\
+ fi ;\
+ $(STAMP) stamp-host
# Host includes dynamic.
-${host_builddir}/c++config.h: ${CONFIG_HEADER} \
+${host_builddir}/c++config.h: ${top_builddir}/config.h \
${glibcxx_srcdir}/include/bits/c++config \
stamp-${host_alias}
@cat ${glibcxx_srcdir}/include/bits/c++config > $@ ;\