summaryrefslogtreecommitdiff
path: root/libstdc++-v3/include/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2005-01-07 19:34:46 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2005-01-07 19:34:46 +0000
commit4d29239659e70a19e6b6d699da1ec22238392ecc (patch)
tree2a9d2695a75fabe6bf837b6f19e0c7c5e5fa5e9a /libstdc++-v3/include/Makefile.am
parent469467ec0e78473839dca27fa97ed74837d99b24 (diff)
downloadgcc-4d29239659e70a19e6b6d699da1ec22238392ecc.tar.gz
2005-01-07 Benjamin Kosnik <bkoz@redhat.com>
* acinclude.m4: Remove CCODECVT_H. * configure: Regenerate. * include/Makefile.am (host_headers_extra): Move to... (ext_headers): ...here. * include/Makefile.in: Regenerate. * include/ext/enc_filebuf: Remove enc_filebuf, consolidate enc_traits to... * config/locale/ieee_1003.1-2001/codecvt_specializations.h: Move... * include/ext/codecvt_specializations.h: ...here. Remove _GLIBCXX_USE___ENC_TRAITS. (__enc_traits): To __encoding_state, put in __gnu_cxx namespace. (enc_char_traits): To __encoding_char_traits, put in __gnu_cxx namespace. * config/locale/generic/codecvt_specializations.h: Remove. * include/bits/codecvt.h: Remove codecvt_specializations.h include. * src/codecvt.cc: Remove __enc_traits::_S_max_size. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@93062 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/include/Makefile.am')
-rw-r--r--libstdc++-v3/include/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/libstdc++-v3/include/Makefile.am b/libstdc++-v3/include/Makefile.am
index ba615fa84aa..be8320a9990 100644
--- a/libstdc++-v3/include/Makefile.am
+++ b/libstdc++-v3/include/Makefile.am
@@ -203,8 +203,8 @@ ext_headers = \
${ext_srcdir}/algorithm \
${ext_srcdir}/array_allocator.h \
${ext_srcdir}/bitmap_allocator.h \
+ ${ext_srcdir}/codecvt_specializations.h \
${ext_srcdir}/debug_allocator.h \
- ${ext_srcdir}/enc_filebuf.h \
${ext_srcdir}/stdio_filebuf.h \
${ext_srcdir}/stdio_sync_filebuf.h \
${ext_srcdir}/functional \
@@ -366,8 +366,7 @@ host_headers_extra = \
${host_builddir}/c++io.h \
${host_builddir}/c++locale.h \
${host_builddir}/messages_members.h \
- ${host_builddir}/time_members.h \
- ${host_builddir}/codecvt_specializations.h
+ ${host_builddir}/time_members.h
thread_host_headers = \
${host_builddir}/gthr.h \