summaryrefslogtreecommitdiff
path: root/libstdc++-v3/testsuite/Makefile.am
diff options
context:
space:
mode:
authorpaolo <paolo@138bc75d-0d04-0410-961f-82ee72b054a4>2010-01-13 11:07:44 +0000
committerpaolo <paolo@138bc75d-0d04-0410-961f-82ee72b054a4>2010-01-13 11:07:44 +0000
commit10c05c9684775cb1d911801238e36d1ef98e4e8a (patch)
tree6b247dd8a2499b56b07d69f4ca296190151f264d /libstdc++-v3/testsuite/Makefile.am
parent7b76dcb9d8a0a1542d23bde7d2b241983f928c6e (diff)
downloadgcc-10c05c9684775cb1d911801238e36d1ef98e4e8a.tar.gz
2010-01-13 Paolo Carlini <paolo.carlini@oracle.com>
* testsuite/Makefile.am (check-debug): Add. * testsuite/Makefile.in: Regenerate. * config.h.in: Likewise. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@155854 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/testsuite/Makefile.am')
-rw-r--r--libstdc++-v3/testsuite/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/libstdc++-v3/testsuite/Makefile.am b/libstdc++-v3/testsuite/Makefile.am
index a2f4fa42986..d20aba7c41f 100644
--- a/libstdc++-v3/testsuite/Makefile.am
+++ b/libstdc++-v3/testsuite/Makefile.am
@@ -1,6 +1,6 @@
## Makefile for the testsuite subdirectory of the GNU C++ Standard library.
##
-## Copyright (C) 2001, 2002, 2003, 2005, 2007, 2009
+## Copyright (C) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010
## Free Software Foundation, Inc.
##
## This file is part of the libstdc++ version 3 distribution.
@@ -186,6 +186,8 @@ check-performance: testsuite_files_performance ${performance_script}
-@(chmod + ${check_performance_script}; \
${check_performance_script} ${glibcxx_srcdir} ${glibcxx_builddir})
+# Runs the testsuite in debug mode.
+debug_flags = "unix/-D_GLIBCXX_DEBUG"
# Runs the testsuite in parallel mode.
libgomp_dir=${glibcxx_builddir}/../libgomp
@@ -199,6 +201,15 @@ parallel_flags="unix/-D_GLIBCXX_PARALLEL/-fopenmp"
# Runs the testsuite in profile mode.
profile_flags = "unix/-D_GLIBCXX_PROFILE"
+check-debug: site.exp
+ outputdir=debug; export outputdir; \
+ if test ! -d $${outputdir}; then \
+ mkdir $${outputdir}; \
+ fi; \
+ srcdir=`$(am__cd) $(srcdir) && pwd`; export srcdir; \
+ EXPECT=$(EXPECT); export EXPECT; \
+ $(MAKE) RUNTESTFLAGS="$(RUNTESTFLAGS) conformance.exp --outdir $${outputdir} --objdir $${outputdir} --target_board=$(debug_flags)" check-DEJAGNU;
+
check-parallel: site.exp
-@(if test ! -d $${libgomp_dir}; then \
echo "Testing parallel mode failed as libgomp not present."; \
@@ -236,4 +247,4 @@ CLEANFILES = *.txt *.tst *.exe core* filebuf_* tmp* ostream_* *.log *.sum \
# To remove directories.
clean-local:
- rm -rf parallel profile
+ rm -rf debug parallel profile