summaryrefslogtreecommitdiff
path: root/libstdc++-v3/testsuite/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2005-04-09 18:50:52 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2005-04-09 18:50:52 +0000
commit8f9661e5837362e9dcbfe16fb3a98f2cfb427cd9 (patch)
treed001d6bca91cb7238d478c927e81a9acbb7abced /libstdc++-v3/testsuite/Makefile.am
parent5a5b37b36aa517a641931268d1d2d301c1f52569 (diff)
downloadgcc-8f9661e5837362e9dcbfe16fb3a98f2cfb427cd9.tar.gz
2005-04-08 Benjamin Kosnik <bkoz@redhat.com>
* testsuite/Makefile.am: Remove libv3test.a. * testsuite/Makefile.in: Regenerate. * testsuite/lib/libstdc++.exp (v3_target_compile): Fix comments. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@97921 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/testsuite/Makefile.am')
-rw-r--r--libstdc++-v3/testsuite/Makefile.am23
1 files changed, 0 insertions, 23 deletions
diff --git a/libstdc++-v3/testsuite/Makefile.am b/libstdc++-v3/testsuite/Makefile.am
index fa013b6774a..eb6a612f6a0 100644
--- a/libstdc++-v3/testsuite/Makefile.am
+++ b/libstdc++-v3/testsuite/Makefile.am
@@ -28,29 +28,6 @@ include $(top_srcdir)/fragment.am
AM_MAKEFLAGS = -j1
AM_RUNTESTFLAGS =
-## CXX is actually a "C" compiler. These are real C++ programs.
-testsuite_flags_script=${glibcxx_builddir}/scripts/testsuite_flags
-CXX = $(shell ${SHELL} ${testsuite_flags_script} --build-cxx)
-GLIBCXX_INCLUDES = $(shell ${SHELL} ${testsuite_flags_script} \
- --build-includes)
-AM_CXXFLAGS = $(shell ${SHELL} ${testsuite_flags_script} --cxxflags)
-
-GLIBGCC_DIR=`$(CC) -print-libgcc-file-name | sed 's,/[^/]*$$,,'`
-GLIBCXX_DIR=${glibcxx_builddir}/src/.libs
-
-CXXLINK = \
- $(LIBTOOL) --tag=CXX --mode=link $(CXX) \
- -R $(GLIBGCC_DIR) -R $(GLIBCXX_DIR) \
- $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -lv3test -L. -o $@
-
-## Build support library.
-noinst_LIBRARIES = libv3test.a
-libv3test_a_SOURCES = \
- testsuite_abi.cc \
- testsuite_allocator.cc \
- testsuite_character.cc \
- testsuite_hooks.cc
-
all-local: stamp_wchar stamp_thread
# Enable wchar_t tests if capable.