summaryrefslogtreecommitdiff
path: root/libstdc++-v3/testsuite/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2005-01-20 20:28:41 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2005-01-20 20:28:41 +0000
commit03ac0bd7feb0e621d9762ad95826a74da59597d8 (patch)
tree98b8d370471b34da8a360184d5aaad62538f83fc /libstdc++-v3/testsuite/Makefile.am
parent6ad1968a7996a35d21a61fd0fe80088cc5899bd1 (diff)
downloadgcc-03ac0bd7feb0e621d9762ad95826a74da59597d8.tar.gz
2005-01-20 Benjamin Kosnik <bkoz@redhat.com>
* testsuite/Makefile.am (check-compile): New. * testsuite/Makefile.in: Regenerate. * scripts/check_compile_time: New. * scripts/check_performance: Tweaks. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@93980 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/testsuite/Makefile.am')
-rw-r--r--libstdc++-v3/testsuite/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/libstdc++-v3/testsuite/Makefile.am b/libstdc++-v3/testsuite/Makefile.am
index 371ab72e43d..1baeb826c4b 100644
--- a/libstdc++-v3/testsuite/Makefile.am
+++ b/libstdc++-v3/testsuite/Makefile.am
@@ -180,6 +180,12 @@ check-performance: testsuite_files_performance ${performance_script}
-@(chmod + ${performance_script}; \
${performance_script} ${glibcxx_srcdir} ${glibcxx_builddir})
+# Runs the testsuite, but in compile only mode, and times it.
+# See script.
+compile_script=${glibcxx_srcdir}/scripts/check_compile
+check-compile: testsuite_files ${compile_script}
+ -@(chmod + ${compile_script}; \
+ ${compile_script} ${glibcxx_srcdir} ${glibcxx_builddir})
# This rule generates all of the testsuite_files* lists at once.
${lists_of_files}: