summaryrefslogtreecommitdiff
path: root/libstdc++-v3/testsuite/Makefile.am
diff options
context:
space:
mode:
authorro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2010-03-01 13:58:48 +0000
committerro <ro@138bc75d-0d04-0410-961f-82ee72b054a4>2010-03-01 13:58:48 +0000
commit68645a6bd5d75bb4455a362b597b9a29ead76d4a (patch)
tree5f0cd1ccb54070ead90f71845e142294d7284ffd /libstdc++-v3/testsuite/Makefile.am
parent941a7344f3d26cb5a93cdcbfd2a1cc322118839f (diff)
downloadgcc-68645a6bd5d75bb4455a362b597b9a29ead76d4a.tar.gz
libstdc++-v3:
PR libstdc++/32499 * testsuite/Makefile.am (check-DEJAGNU $(check_DEJAGNU_normal_targets)): Export AR, RANLIB. * testsuite/Makefile.in: Regenerate. toplevel: PR libstdc++/32499 * configure.ac (RANLIB): Default to true. (STRIP): Likewise. (RANLIB_FOR_TARGET): Remove superfluous : argument. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@157144 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/testsuite/Makefile.am')
-rw-r--r--libstdc++-v3/testsuite/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/libstdc++-v3/testsuite/Makefile.am b/libstdc++-v3/testsuite/Makefile.am
index d20aba7c41f..c81db8cbfcd 100644
--- a/libstdc++-v3/testsuite/Makefile.am
+++ b/libstdc++-v3/testsuite/Makefile.am
@@ -103,6 +103,8 @@ $(check_DEJAGNU_normal_targets): check-DEJAGNUnormal%: normal%/site.exp
# Run the testsuite in normal mode.
check-DEJAGNU $(check_DEJAGNU_normal_targets): check-DEJAGNU%: site.exp
+ AR="$(AR)"; export AR; \
+ RANLIB="$(RANLIB)"; export RANLIB; \
if [ -z "$*$(filter-out --target_board=%, $(RUNTESTFLAGS))" ] \
&& [ "$(filter -j, $(MFLAGS))" = "-j" ]; then \
$(MAKE) $(AM_MAKEFLAGS) check-DEJAGNUnormal0 check-DEJAGNUnormal1 \