summaryrefslogtreecommitdiff
path: root/libstdc++-v3/testsuite/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2005-06-20 06:48:28 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2005-06-20 06:48:28 +0000
commit099c5a786b05502cd3fc261ad87c4dd1b3771ca7 (patch)
tree60c1e4cbc804709e773671a81d783672ffa7bec2 /libstdc++-v3/testsuite/Makefile.am
parent802fd2c408534f6f7a2fd5dc8b3b8b36a981a461 (diff)
downloadgcc-099c5a786b05502cd3fc261ad87c4dd1b3771ca7.tar.gz
make
2005-06-19 Benjamin Kosnik <bkoz@redhat.com> PR libstdc++/22111 * acinclude.m4 (GLIBCXX_CONFIGURE_TESTSUITE): Remove GLIBCXX_TEST_ABI. Remove duplicate _GLIBCXX_ASM_SYMVER define. Don't enable abi testing unless versioned. * configure: Regenerate. * testsuite/Makefile.am (check-abi): Remove conditional. * testsuite/Makefile.in: Regenerate. * testsuite/libstdc++-abi/abi.exp: Call build_support, then check v3-symver before proceeding. * testsuite/lib/libstdc++.exp (libstdc++-dg-test): Set v3-symvers if _GLIBCXX_SYMVER. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@101204 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/testsuite/Makefile.am')
-rw-r--r--libstdc++-v3/testsuite/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/libstdc++-v3/testsuite/Makefile.am b/libstdc++-v3/testsuite/Makefile.am
index 68e0e806c8f..facf63a900f 100644
--- a/libstdc++-v3/testsuite/Makefile.am
+++ b/libstdc++-v3/testsuite/Makefile.am
@@ -89,14 +89,10 @@ new-abi-baseline:
fi; \
${extract_symvers} ../src/.libs/libstdc++.so $${output})
-if GLIBCXX_TEST_ABI
# Use 'new-abi-baseline' to create an initial symbol file. Then run
# 'check-abi' to test for changes against that file.
check-abi: baseline_symbols site.exp
-@runtest --tool libstdc++ abi.exp
-else
-check-abi:
-endif
# Runs the testsuite, but in compile only mode.
# Can be used to test sources with non-GNU FE's at various warning