summaryrefslogtreecommitdiff
path: root/libstdc++-v3/testsuite/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2002-08-02 16:04:16 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2002-08-02 16:04:16 +0000
commit3aba0096b6c3d315553a253dfc83b3e802ed4781 (patch)
treef09969269dffbedb05335c80ca06847521a7611c /libstdc++-v3/testsuite/Makefile.am
parent428fa5f709fabc0ef1cebd6e9022c6871252de76 (diff)
downloadgcc-3aba0096b6c3d315553a253dfc83b3e802ed4781.tar.gz
2002-08-02 Benjamin Kosnik <bkoz@redhat.com>
Revert PR libstdc++/6594 * src/strstream.cc (strstreambuf): Revert. (strstreambuf::overflow): Same. (strstreambuf::~strstreambuf): Same. * testsuite/backward/strstream_members.cc (test02): Add. * docs/html/abi.txt: Update. Spell check. * testsuite/19_diagnostics/stdexceptions.cc (test04): Add bool test. * testsuite/Makefile.am (INCLUDES): Add LIBSUPCXX_INCLUDES. * testsuite/Makefile.in: Regenerate. * testsuite/testsuite_hooks.h: Use __throw_exception_again, include functexcept.h so that -fno-exceptions will build. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@55988 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/testsuite/Makefile.am')
-rw-r--r--libstdc++-v3/testsuite/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/libstdc++-v3/testsuite/Makefile.am b/libstdc++-v3/testsuite/Makefile.am
index 7733010d63a..c0e7be31b9e 100644
--- a/libstdc++-v3/testsuite/Makefile.am
+++ b/libstdc++-v3/testsuite/Makefile.am
@@ -36,9 +36,11 @@ RUNTEST = `if [ -f @glibcpp_srcdir@/../dejagnu/runtest ] ; then \
AM_RUNTESTFLAGS =
RUNTESTFLAGS =
-CXX = @glibcpp_CXX@ @GLIBCPP_INCLUDES@
+CXX = @glibcpp_CXX@
# Use common includes from acinclude.m4/GLIBCPP_EXPORT_INCLUDES
-INCLUDES = @TOPLEVEL_INCLUDES@
+INCLUDES = \
+ -nostdinc++ \
+ @GLIBCPP_INCLUDES@ @LIBSUPCXX_INCLUDES@ @TOPLEVEL_INCLUDES@
noinst_LIBRARIES = libv3test.a