summaryrefslogtreecommitdiff
path: root/libstdc++-v3/testsuite/Makefile.am
diff options
context:
space:
mode:
authorpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2003-08-27 21:29:43 +0000
committerpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2003-08-27 21:29:43 +0000
commit6f4a1f789830b196b3ede71d2849f0bebb592dec (patch)
tree5d6a0b7359774eca07febd48917298fb550e6aa3 /libstdc++-v3/testsuite/Makefile.am
parent9ac302040291c3e0488e542080314a54370889fd (diff)
downloadgcc-6f4a1f789830b196b3ede71d2849f0bebb592dec.tar.gz
2003-08-27 Phil Edwards <pme@gcc.gnu.org>
* Makefile.am: Remove trailing whitespace. Remove needless "foo = @foo@" assignments. Replace direct uses of @foo@ with $(foo). * include/Makefile.am: Likewise. * libmath/Makefile.am: Likewise. * libsupc++/Makefile.am: Likewise. * po/Makefile.am: Likewise. * src/Makefile.am: Likewise. * testsuite/Makefile.am: Likewise. * Makefile.in, include/Makefile.in, libmath/Makefile.in, libsupc++/Makefile.in, po/Makefile.in, src/Makefile.in, testsuite/Makefile.in: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@70865 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/testsuite/Makefile.am')
-rw-r--r--libstdc++-v3/testsuite/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/libstdc++-v3/testsuite/Makefile.am b/libstdc++-v3/testsuite/Makefile.am
index 4248a14fe0c..3a03189b7b8 100644
--- a/libstdc++-v3/testsuite/Makefile.am
+++ b/libstdc++-v3/testsuite/Makefile.am
@@ -52,7 +52,7 @@ libv3test_a_SOURCES = testsuite_hooks.cc testsuite_allocator.cc
if GLIBCXX_TEST_ABI
noinst_PROGRAMS = abi_check
else
-noinst_PROGRAMS =
+noinst_PROGRAMS =
endif
abi_check_SOURCES = abi_check.cc
@@ -69,9 +69,8 @@ endif
# This is automatically run after the generated check-DEJAGNU rule.
check-local: check-abi
-baseline_dir = @baseline_dir@
baseline_file = ${baseline_dir}/baseline_symbols.txt
-extract_symvers = @glibcxx_srcdir@/scripts/extract_symvers
+extract_symvers = $(glibcxx_srcdir)/scripts/extract_symvers
current_symbols.txt: ${extract_symvers} ../src/.libs/libstdc++.so
-@(${extract_symvers} ../src/.libs/libstdc++.so current_symbols.txt)
@@ -84,7 +83,7 @@ baseline_symbols:
exit 1; \
fi; true)
-new-abi-baseline:
+new-abi-baseline:
-@$(mkinstalldirs) ${baseline_dir}
-@(output=${baseline_file}; \
if test -f $${output}; then \
@@ -101,7 +100,7 @@ check-abi: abi_check baseline_symbols current_symbols.txt
-@(./abi_check --check ./current_symbols.txt ${baseline_file} \
2>&1 | tee libstdc++-abi.sum)
-check-abi-verbose: abi_check baseline_symbols current_symbols.txt
+check-abi-verbose: abi_check baseline_symbols current_symbols.txt
-@(./abi_check --check-verbose ./current_symbols.txt ${baseline_file} \
2>&1 | tee libstdc++-abi.sum)
@@ -126,7 +125,7 @@ check-script-install: ${survey_script}
${survey_script} 0)
-# Runs the testsuite/performance tests.
+# Runs the testsuite/performance tests.
# Some of these tests create large (~75MB) files, allocate huge
# ammounts of memory, or otherwise tie up machine resources. Thus,
# running this is off by default.
@@ -147,4 +146,4 @@ check-script check-script-install check-performance
# By adding these files here, automake will remove them for 'make clean'
CLEANFILES = *.txt *.tst *.exe core* filebuf_* tmp* ostream_* *.log *.sum \
- testsuite_* site.exp abi_check baseline_symbols
+ testsuite_* site.exp abi_check baseline_symbols