summaryrefslogtreecommitdiff
path: root/libstdc++-v3/testsuite/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2004-05-13 12:50:53 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2004-05-13 12:50:53 +0000
commite2585cd835ae2dfa42f12b9ff4bbb56d339a83c9 (patch)
tree63b5caca1dfe3a1f87e96af76329f6f1565e7266 /libstdc++-v3/testsuite/Makefile.am
parent578377eba22f40aa2699b0451be8f385125de557 (diff)
downloadgcc-e2585cd835ae2dfa42f12b9ff4bbb56d339a83c9.tar.gz
2004-05-13 Benjamin Kosnik <bkoz@redhat.com>
* docs/html/abi.html: New. * docs/html/abi.txt: Remove. * docs/html/documentation.html: Add link. * testsuite/Makefile.am: Add files. * testsuite/Makefile.in: Regenerated. * testsuite/abi_check.cc: Move and modify code into... * testsuite/testsuite_abi.cc: Add. * testsuite/testsuite_abi.h: Add. * docs/html/17_intro/TODO: Update. * include/bits/stl_pair.h: Format. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@81781 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/testsuite/Makefile.am')
-rw-r--r--libstdc++-v3/testsuite/Makefile.am23
1 files changed, 14 insertions, 9 deletions
diff --git a/libstdc++-v3/testsuite/Makefile.am b/libstdc++-v3/testsuite/Makefile.am
index c58d008d00c..9e11ac30ae9 100644
--- a/libstdc++-v3/testsuite/Makefile.am
+++ b/libstdc++-v3/testsuite/Makefile.am
@@ -39,18 +39,14 @@ GLIBCXX_DIR=${glibcxx_builddir}/src/.libs
CXXLINK = \
$(LIBTOOL) --tag=CXX --mode=link $(CXX) \
-R $(GLIBGCC_DIR) -R $(GLIBCXX_DIR) \
- $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@
-
-# Generated lists of files to run. All of these names are valid make
-# targets, if you wish to generate a list manually.
-lists_of_files = \
- testsuite_files \
- testsuite_files_interactive \
- testsuite_files_performance
+ $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -lv3test -L. -o $@
## Build support library.
noinst_LIBRARIES = libv3test.a
-libv3test_a_SOURCES = testsuite_hooks.cc testsuite_allocator.cc
+libv3test_a_SOURCES = \
+ testsuite_abi.cc \
+ testsuite_allocator.cc \
+ testsuite_hooks.cc
## Build support utilities.
if GLIBCXX_TEST_ABI
@@ -59,6 +55,7 @@ else
noinst_PROGRAMS =
endif
abi_check_SOURCES = abi_check.cc
+abi_check_DEPENDENCIES = libv3test.a
all-local: stamp_wchar testsuite_files
@@ -70,6 +67,14 @@ else
stamp_wchar:
endif
+# Generated lists of files to run. All of these names are valid make
+# targets, if you wish to generate a list manually.
+lists_of_files = \
+ testsuite_files \
+ testsuite_files_interactive \
+ testsuite_files_performance
+
+
# We need more things in site.exp, but automake completely controls the
# creation of that file; there's no way to append to it without messing up
# the dependancy chains. So we overrule automake. This rule is exactly