summaryrefslogtreecommitdiff
path: root/lto-plugin/Makefile.am
diff options
context:
space:
mode:
authorktietz <ktietz@138bc75d-0d04-0410-961f-82ee72b054a4>2011-02-07 08:20:56 +0000
committerktietz <ktietz@138bc75d-0d04-0410-961f-82ee72b054a4>2011-02-07 08:20:56 +0000
commit3a9d8500bea35d8fde4c8ac5948ea8e42426de64 (patch)
tree1720c83155cfd109562b677dcf45ec9fbd4c397e /lto-plugin/Makefile.am
parent2e8ba7b3acf00cbf99ecb468322ee8f298d9eb68 (diff)
downloadgcc-3a9d8500bea35d8fde4c8ac5948ea8e42426de64.tar.gz
2011-02-07 Kai Tietz <kai.tietz@onevision.com>
PR lto/47225 * Makefile.am (Wl): New helper for encoding -Wl,. (liblto_plugin_la_LIBADD): Use -Wl for libiberty library. * Makefile.in: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@169877 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'lto-plugin/Makefile.am')
-rw-r--r--lto-plugin/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/lto-plugin/Makefile.am b/lto-plugin/Makefile.am
index a51bc4a9739..1e4405389cf 100644
--- a/lto-plugin/Makefile.am
+++ b/lto-plugin/Makefile.am
@@ -11,11 +11,13 @@ AM_CPPFLAGS = -I$(top_srcdir)/../include $(DEFS)
AM_CFLAGS = -Wall -Werror
AM_LIBTOOLFLAGS = --tag=disable-static
+# This can go away when libiberty becomes a normal convenience library
+Wl=-Wl,
libexecsub_LTLIBRARIES = liblto_plugin.la
liblto_plugin_la_SOURCES = lto-plugin.c
liblto_plugin_la_LIBADD = \
- $(if $(wildcard ../libiberty/pic/libiberty.a),../libiberty/pic/libiberty.a,)
+ $(if $(wildcard ../libiberty/pic/libiberty.a),$(Wl)../libiberty/pic/libiberty.a,)
# Note that we intentionally override the bindir supplied by ACX_LT_HOST_FLAGS
liblto_plugin_la_LDFLAGS = $(lt_host_flags) -bindir $(libexecsubdir) \
$(if $(wildcard ../libiberty/pic/libiberty.a),,-Wc,../libiberty/libiberty.a)