summaryrefslogtreecommitdiff
path: root/lto-plugin/Makefile.am
diff options
context:
space:
mode:
authorrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2011-02-12 15:48:15 +0000
committerrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2011-02-12 15:48:15 +0000
commit507c6564768da800df29cf9f4f2d4087c5de7af6 (patch)
tree7a3e8e40020818dec055f8ed40cc15374e050bd0 /lto-plugin/Makefile.am
parent99f54fbbd39aa57752204b984bcbe9b2d7f7bfe9 (diff)
downloadgcc-507c6564768da800df29cf9f4f2d4087c5de7af6.tar.gz
Fix minor build system issues in lto-plugin.
lto-plugin/: * Makefile.am (all-local): Rename from 'all'. (gcc_build_dir): Use $(host_subdir). * Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@170075 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'lto-plugin/Makefile.am')
-rw-r--r--lto-plugin/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/lto-plugin/Makefile.am b/lto-plugin/Makefile.am
index fd9ea625f9b..4067c43150a 100644
--- a/lto-plugin/Makefile.am
+++ b/lto-plugin/Makefile.am
@@ -12,7 +12,7 @@ AM_CFLAGS = -Wall -Werror
AM_LIBTOOLFLAGS = --tag=disable-static
libexecsub_LTLIBRARIES = liblto_plugin.la
-gcc_build_dir = ../gcc
+gcc_build_dir = ../$(host_subdir)/gcc
in_gcc_libs = $(foreach lib, $(libexecsub_LTLIBRARIES), $(gcc_build_dir)/$(lib))
# Can be removed when libiberty becomes a normal convenience library
@@ -27,7 +27,7 @@ liblto_plugin_la_LDFLAGS = $(lt_host_flags) -module -bindir $(libexecsubdir) \
liblto_plugin_la_DEPENDENCIES = $(if $(wildcard \
../libiberty/pic/libiberty.a),../libiberty/pic/libiberty.a,)
-all: $(in_gcc_libs)
+all-local: $(in_gcc_libs)
$(in_gcc_libs) : $(gcc_build_dir)/%: %
@if test "X`dlname=; . ./$*; echo dlname:$$dlname`" = "Xdlname:"; then \