summaryrefslogtreecommitdiff
path: root/texinfo/util/Makefile.am
diff options
context:
space:
mode:
authorJeff Law <law@gcc.gnu.org>1998-03-22 21:41:58 -0700
committerJeff Law <law@gcc.gnu.org>1998-03-22 21:41:58 -0700
commit1eb3e8442f8c549c9b2ed21ca75eb7fb12b10b0d (patch)
tree9bc386a0875ecd26d247a4eb18407b6c59020a25 /texinfo/util/Makefile.am
parent34b6478b59f51c9d5b2b634ea0aefa6813cdbb2a (diff)
downloadgcc-1eb3e8442f8c549c9b2ed21ca75eb7fb12b10b0d.tar.gz
Initial revision
From-SVN: r18770
Diffstat (limited to 'texinfo/util/Makefile.am')
-rw-r--r--texinfo/util/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/texinfo/util/Makefile.am b/texinfo/util/Makefile.am
new file mode 100644
index 00000000000..d1f973e2d8b
--- /dev/null
+++ b/texinfo/util/Makefile.am
@@ -0,0 +1,23 @@
+## Makefile.am for texinfo/util.
+## $Id: Makefile.am,v 1.1 1998/03/23 04:43:11 law Exp $
+## Run automake in .. to produce Makefile.in from this.
+
+bin_PROGRAMS = texindex
+bin_SCRIPTS = texi2dvi
+
+## CYGNUS LOCAL: Build install-inf locally, and install it as
+## install-info, to avoid confusing with the install-info target
+## generated by automake --cygnus.
+noinst_PROGRAMS = install-inf
+install_inf_SOURCES = install-info.c
+
+localedir = $(datadir)/locale
+INCLUDES = -I$(top_srcdir)/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
+LDADD = ../lib/libtxi.a @INTLLIBS@
+
+EXTRA_DIST = README deref.c fixfonts gen-dir-node tex3patch texi2dvi \
+ update-info
+
+install-exec-local: $(noinst_PROGRAMS)
+ $(mkinstalldirs) $(bindir)
+ $(INSTALL_PROGRAM) install-inf$(EXEEXT) $(bindir)/`echo install-info$(EXEEXT)|sed '$(transform)'`; \