summaryrefslogtreecommitdiff
path: root/zlib/Makefile.am
diff options
context:
space:
mode:
authorgreen <green@138bc75d-0d04-0410-961f-82ee72b054a4>2000-09-03 19:54:20 +0000
committergreen <green@138bc75d-0d04-0410-961f-82ee72b054a4>2000-09-03 19:54:20 +0000
commit4583874ff98388401bae18033dd2fdbf49699e1d (patch)
tree1baf06517631208468de4874059d0d7e5586a5b1 /zlib/Makefile.am
parent5e3840e1992a75e2d1cae71114ac14ea9aa360f5 (diff)
downloadgcc-4583874ff98388401bae18033dd2fdbf49699e1d.tar.gz
Sun Sep 3 12:37:12 2000 Anthony Green <green@redhat.com>
* configure.in: Add TARGET_LIBRARY conditional. * configure: Rebuilt. * Makefile.am: If we're building a build host library, call the library libz.a and don't use libtool. * Makefile.in: Rebuilt. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@36121 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'zlib/Makefile.am')
-rw-r--r--zlib/Makefile.am17
1 files changed, 11 insertions, 6 deletions
diff --git a/zlib/Makefile.am b/zlib/Makefile.am
index e6e97c9752e..80de4ef763f 100644
--- a/zlib/Makefile.am
+++ b/zlib/Makefile.am
@@ -19,17 +19,22 @@ toolexecdir = $(exec_prefix)/$(target_alias)
toolexeclibdir = $(toolexecdir)/lib$(MULTISUBDIR)
endif
-## We don't use `libz.la' because we don't want to conflict with a
-## system library of that name.
-toolexeclib_LTLIBRARIES = @target_all@
-EXTRA_LTLIBRARIES = libzgcj.la
-
-libzgcj_la_SOURCES = adler32.c compress.c crc32.c deflate.c deflate.h \
+ZLIB_SOURCES = adler32.c compress.c crc32.c deflate.c deflate.h \
gzio.c infblock.c infblock.h infcodes.c infcodes.h inffast.c inffast.h \
inffixed.h inflate.c inftrees.c inftrees.h infutil.c infutil.h trees.c \
trees.h uncompr.c zconf.h zlib.h zutil.c zutil.h
+if TARGET_LIBRARY
+## We don't use `libz.la' because we don't want to conflict with a
+## system library of that name.
+toolexeclib_LTLIBRARIES = @target_all@
+EXTRA_LTLIBRARIES = libzgcj.la
+libzgcj_la_SOURCES = $(ZLIB_SOURCES)
libzgcj_la_LDFLAGS = -version-info 0:0:0 -rpath $(toolexeclibdir)
+else
+toolexeclib_LIBRARIES = libz.a
+libz_a_SOURCES = $(ZLIB_SOURCES)
+endif
# Work around what appears to be a GNU make bug handling MAKEFLAGS
# values defined in terms of make variables, as is the case for CC and