summaryrefslogtreecommitdiff
path: root/zlib/Makefile.am
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>1999-05-05 10:04:39 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>1999-05-05 10:04:39 +0000
commitfe5b206288efe97f4958b9dc78ecc6d10c5c23a8 (patch)
tree694549bb82390fd46f0c242e3470d5e517ffcdb1 /zlib/Makefile.am
parenteef4cb1332c93f3711b00837a6d94db47bcd7a00 (diff)
downloadgcc-fe5b206288efe97f4958b9dc78ecc6d10c5c23a8.tar.gz
* Makefile.in: Replace with automake-generated file.
* Makefile.am: New file. * configure: Replaced with autoconf-generated script. * aclocal.m4: New file. * acinclude.m4: New file. * configure.in: New file. * Makefile: Removed. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@26777 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'zlib/Makefile.am')
-rw-r--r--zlib/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/zlib/Makefile.am b/zlib/Makefile.am
new file mode 100644
index 00000000000..12ff04e9a34
--- /dev/null
+++ b/zlib/Makefile.am
@@ -0,0 +1,25 @@
+## Process this file with automake to create Makefile.in.
+
+AUTOMAKE_OPTIONS = cygnus
+
+# Multilib support variables.
+MULTISRCTOP =
+MULTIBUILDTOP =
+MULTIDIRS =
+MULTISUBDIR =
+MULTIDO = true
+MULTICLEAN = true
+
+toolexecdir = $(exec_prefix)/$(target_alias)
+toolexeclibdir = $(toolexecdir)/lib$(MULTISUBDIR)
+
+## We don't use `libz.la' because we don't want to conflict with a
+## system library of that name.
+toolexeclib_LTLIBRARIES = libzgcj.la
+
+libzgcj_la_SOURCES = adler32.c compress.c crc32.c deflate.c deflate.h \
+gzio.c infblock.c infblock.h infcodes.c infcodes.h inffast.c inffast.h \
+inffixed.h inflate.c inftrees.c inftrees.h infutil.c infutil.h trees.c \
+trees.h uncompr.c zconf.h zlib.h zutil.c zutil.h
+
+libzgcj_la_LDFLAGS = -release $(VERSION) -rpath $(toolexeclibdir)