summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 27 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index b2e841437be..401d2dca4bf 100644
--- a/configure.in
+++ b/configure.in
@@ -151,7 +151,8 @@ target_libraries="target-libiberty \
target-libgfortran \
${libgcj} \
target-libobjc \
- target-libada"
+ target-libada \
+ target-libgomp"
# these tools are built using the target libraries, and are intended to
# run only in the target environment
@@ -341,7 +342,7 @@ no)
;;
"")
case "${target}" in
- *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu)
+ *-*-linux* | *-*-gnu* | *-*-k*bsd*-gnu)
# Enable libmudflap by default in GNU and friends.
;;
*-*-freebsd*)
@@ -354,6 +355,30 @@ no)
esac
esac
+# Allow --disable-libgomp to exclude target-libgomp
+case $enable_libgomp in
+yes)
+ ;;
+no)
+ noconfigdirs="$noconfigdirs target-libgomp"
+ ;;
+"")
+ # Enable libgomp by default on hosted POSIX systems.
+ case "${target}" in
+ *-*-linux* | *-*-gnu* | *-*-k*bsd*-gnu)
+ ;;
+ *-*-netbsd* | *-*-freebsd* | *-*-openbsd*)
+ ;;
+ *-*-solaris2* | *-*-sysv4* | *-*-irix* | *-*-osf* | *-*-hpux*)
+ ;;
+ *-*-darwin*)
+ ;;
+ *)
+ noconfigdirs="$noconfigdirs target-libgomp"
+ ;;
+ esac
+esac
+
case "${target}" in
*-*-chorusos)