summaryrefslogtreecommitdiff
path: root/fastjar/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fastjar/Makefile.am')
-rw-r--r--fastjar/Makefile.am24
1 files changed, 12 insertions, 12 deletions
diff --git a/fastjar/Makefile.am b/fastjar/Makefile.am
index eeff9a1af9d..901e8995d8a 100644
--- a/fastjar/Makefile.am
+++ b/fastjar/Makefile.am
@@ -45,12 +45,12 @@ AM_CPPFLAGS = -I. -I$(top_srcdir) $(ZINCS) -I$(top_srcdir)/../include
LIBIBERTY = ../libiberty/libiberty.a
-bin_PROGRAMS = jar grepjar
-jar_SOURCES = jartool.c dostime.c compress.c pushback.c shift.c jartool.h \
+bin_PROGRAMS = fastjar grepjar
+fastjar_SOURCES = jartool.c dostime.c compress.c pushback.c shift.c jartool.h \
zipfile.h dostime.h compress.h pushback.h shift.h
-jar_LDADD = $(ZLIBS) $(LIBIBERTY)
-jar_DEPENDENCIES = $(ZDEPS) $(LIBIBERTY)
-jar_CPPFLAGS = $(AM_CPPFLAGS) -DWITH_SHIFT_DOWN
+fastjar_LDADD = $(ZLIBS) $(LIBIBERTY)
+fastjar_DEPENDENCIES = $(ZDEPS) $(LIBIBERTY)
+fastjar_CPPFLAGS = $(AM_CPPFLAGS) -DWITH_SHIFT_DOWN
grepjar_SOURCES = jargrep.c dostime.c compress.c pushback.c jartool.h \
zipfile.h dostime.h compress.h pushback.h
@@ -65,7 +65,7 @@ info_TEXINFOS = fastjar.texi
fastjar_TEXINFOS = \
../gcc/doc/include/gcc-common.texi \
../gcc/doc/include/gpl.texi
-man_MANS = jar.1 grepjar.1
+man_MANS = fastjar.1 grepjar.1
EXTRA_DIST = $(man_MANS)
TEXI2POD = perl $(srcdir)/../contrib/texi2pod.pl
@@ -76,10 +76,10 @@ POD2MAN = pod2man --center="GNU" --release="gcc-@gcc_version@"
mv -f $(@).T$$$$ $@) || \
(rm -f $(@).T$$$$ && exit 1)
-.INTERMEDIATE: jar.pod grepjar.pod
+.INTERMEDIATE: fastjar.pod grepjar.pod
-jar.pod: $(srcdir)/fastjar.texi
- -$(TEXI2POD) -D jar $< > $@
+fastjar.pod: $(srcdir)/fastjar.texi
+ -$(TEXI2POD) -D fastjar $< > $@
grepjar.pod: $(srcdir)/fastjar.texi
-$(TEXI2POD) -D grepjar $< > $@
@@ -97,13 +97,13 @@ endif
all-local: $(STAMP_GENINSRC)
-stamp-geninsrc: jar.1 grepjar.1 fastjar.info
- -cp -p $(top_builddir)/jar.1 $(srcdir)/jar.1
+stamp-geninsrc: fastjar.1 grepjar.1 fastjar.info
+ -cp -p $(top_builddir)/fastjar.1 $(srcdir)/fastjar.1
-cp -p $(top_builddir)/grepjar.1 $(srcdir)/grepjar.1
-cp -p $(top_builddir)/fastjar.info $(srcdir)/fastjar.info
touch $@
CLEANFILES = stamp-geninsrc
-MAINTAINERCLEANFILES = $(srcdir)/jar.1 \
+MAINTAINERCLEANFILES = $(srcdir)/fastjar.1 \
$(srcdir)/grepjar.1 \
$(srcdir)/fastjar.info