summaryrefslogtreecommitdiff
path: root/fixincludes/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'fixincludes/configure.ac')
-rw-r--r--fixincludes/configure.ac32
1 files changed, 24 insertions, 8 deletions
diff --git a/fixincludes/configure.ac b/fixincludes/configure.ac
index e0058b11640..8499032db81 100644
--- a/fixincludes/configure.ac
+++ b/fixincludes/configure.ac
@@ -9,24 +9,40 @@ AC_PROG_CC
# Choose one or two-process fix methodology. Systems that cannot handle
# bi-directional pipes must use the two process method.
#
-case $host in
+AC_ARG_ENABLE([twoprocess],
+[ --enable-twoprocess Use a separate process to apply the fixes],
+[if test "x$enable_twoprocess" = yes; then
+ TARGET=twoprocess
+else
+ TARGET=oneprocess
+fi],
+[case $host in
i?86-*-msdosdjgpp* | \
+ i?86-*-mingw32* | \
*-*-beos* )
TARGET=twoprocess
- AC_DEFINE(SEPARATE_FIX_PROC, 1, [Define if testing and fixing are done by separate process])
;;
- vax-dec-bsd* )
+ * )
TARGET=oneprocess
- AC_DEFINE(exit, xexit, [Define to xexit if the host system does not support atexit])
- AC_DEFINE(atexit, xatexit, [Define to xatexit if the host system does not support atexit])
;;
+esac])
+AC_SUBST(TARGET)
- * )
- TARGET=oneprocess
+if test $TARGET = twoprocess; then
+ AC_DEFINE(SEPARATE_FIX_PROC, 1,
+ [Define if testing and fixing are done by separate process])
+fi
+
+case $host in
+ vax-dec-bsd* )
+ AC_DEFINE(exit, xexit, [Define to xexit if the host system does not support atexit])
+ AC_DEFINE(atexit, xatexit, [Define to xatexit if the host system does not support atexit])
;;
esac
-AC_SUBST(TARGET)
+
+AC_DEFINE_UNQUOTED([EXE_EXT], "$ac_exeext",
+ [Defined to the executable file extension on the host system])
# Checks for header files.
AC_HEADER_STDC